Frage zum Forum: Kann man die desktop notifications abstellen ?



  • Hi,

    Wenn ich mich hier im Forum bewege, erscheint oben eine Art Banner mit dem Text
    “MediathekView-Forum needs your permission to activate desktop notifications.”

    Nun widersprechen desktop notifications meiner normalen Arbeitsweise: Ich konzentriere mich auf das, was ich gerade tue, und erst wenn ich mit der Sache oder einem Abschnitt davon fertig bin, schaue ich nach, ob es woanders was neues gibt.
    Deshalb schalte ich die ab, wo immer es möglich ist.

    Man kann die permission zwar im Browser abschalten, aber die Forums-Software fragt halt bei jedem Refresh der Seite erneut nach. Den Teil wäre ich auch gerne noch los, weil es … wie soll ich sagen … einen sozialen Druck erzeugt. 😉

    In den Profileinstellungen habe ich schon alles mögliche abgestellt. Scheinbar ist da nicht gie für mich richtige Option dabei. Gibt es die überhaupt ?

    Vielen Dank und noch mehr Grüße 🙂


  • Globaler Moderator

    @Viereckige-Augen

    Kannst du das bitte etwas näher erläutern (Betriebssystem, Browser etc.), Ich habe so einen “Banner” unter Windows 7 und 10 in den Browsern Firefox, Opera, IE noch nie gesehen. Ebenfalls nicht auf Androidtablets mit diversen Browsern.
    Screenshot wäre vllt. auch ganz nett.

    Gruß



  • Ich benutze Firefox auf Linux, und der Banner sieht so aus:

    Screenshot_Desktop_Notificatons.png

    Desktop Notificatons sind so Popup-Nachrichten, die bei gewissen events in der Taskleiste angezeigt werden. Ich nehme an, im Forum wäre das immer wenn es eine neue Antwort auf meinen Beitrag gibt.

    Bei Windows kenne ich sowas ähnliches (von früher) z.B. nachdem man einen externen Datenträger “sicher entfernt” hat und man ihn jetzt abziehen kann. Oder vom Mailprogramm wenn es neue Mails gibt usw.



  • @Viereckige-Augen
    In Firefox solltest Du diese Banneranfragen grundsätzlich, d.h. für alle Seiten, ausschalten können:

    Einstellungen -> Datenschutz & Sicherheit -> Berechtigungen -> Benachrichtigungen/Einstellungen – und Haken setzen bei “Neue Anfragen zum Anzeigen von Benachrichtigungen blockieren”. Auf “Änderungen speichern” klicken und zuletzt Firefox neu starten.



  • @Viereckige-Augen sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Ich benutze Firefox auf Linux, und der Banner sieht so aus:

    Click mal Strg+I , dann kommst du in die Site-Einstellungen und kannst bei Permission “Send Notifications” blocken, auf per.-Site-Basis, oder aber wie beschrieben in den Einstellungen für alle Seiten



  • @maroc sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    @Viereckige-Augen
    In Firefox solltest Du diese Banneranfragen grundsätzlich, d.h. für alle Seiten, ausschalten können:

    Einstellungen -> Datenschutz & Sicherheit -> Berechtigungen -> Benachrichtigungen/Einstellungen – und Haken setzen bei “Neue Anfragen zum Anzeigen von Benachrichtigungen blockieren”. Auf “Änderungen speichern” klicken und zuletzt Firefox neu starten.

    Hilft leider nicht. Denn der Banner ist nicht die Desktopnotifikation, sondern eine Frage ob man die Notifikation haben will. Ist gut gemeint aber schlecht umgesetzt. Denn die Forensoftware merkt sich die Auswahl nicht und nervt deswegen immer wieder.



  • @mvsfsvm sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Ist gut gemeint aber schlecht umgesetzt. Denn die Forensoftware merkt sich die Auswahl nicht und nervt deswegen immer wieder.

    Die Foren Software merkt sich das wohl über Cookies (hast Du die erlaubt für die Seite)?



  • @mvsfsvm sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Hilft leider nicht. Denn der Banner ist nicht die Desktopnotifikation, sondern eine Frage ob man die Notifikation haben will.

    Also bei mir funktioniert mit oben beschriebenen Methoden das Blockieren der Frage sowohl für einzelne Sites als auch generell für alle. Schließlich heißt es ja in den Firefox-Einstellungen ausdrücklich “Neue Anfragen zum Anzeigen von Benachrichtigungen blockieren”. Und weiter: “Dies wird alle nicht oben aufgeführten Websites daran hindern, um die Erlaubnis zum Anzeigen von Benachrichtigungen anzufragen.”

    Nachtrag: Wobei, genau gesagt, beides blockiert wird: Anfragen und Benachrichtigungen …



  • @media_fread sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Die Foren Software merkt sich das wohl über Cookies (hast Du die erlaubt für die Seite)?

    Ich habe meinen Firefox so eingestellt, dass alle Cookies beim Beenden des Browsers gelöscht werden, gleichwohl funktioniert die Blockade der Benachrichtigungsanfragen bei mir dauerhaft.

    Nicht die Foren-Software, sondern der Firefox merkt sich die Einstellung.



  • Es geht gar nicht um die Blockade der Benachrichtigung. Der orange Balken ist keine. Auch mit dem FF muss ich den immer wieder schließen. Allerdings bleibt er bis zum Ende der Session weg.

    Bei Opera bekomme ich den in neuen Tabs wieder. Komisch finde ich auch, dass in Opera 5 Cookies und in FF nur 2 verwendet werden.

    Edit: Auch im FF gibts den Balken in neuen Tabs wieder. Der FF merkt sich da gar nichts und auch das Forum nicht. Wenn sich das Forum das merken würde, dann müsste es auch eine Einstellung dafür geben. Ich habe die jedoch nicht gefunden.



  • @mvsfsvm sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Es geht gar nicht um die Blockade der Benachrichtigung. Der orange Balken ist keine.

    Dem Fragesteller geht es doch wohl um beides, d.h. er möchte gerne den orangen Balken und die (eigentlichen) Benachrichtigungen unterbinden.

    Der FF merkt sich da gar nichts […]

    Offensichtlich hat mein FF ein besseres Gedächtnis als Deiner 🤤. Voraussetzung ist die oben beschriebene Firefox-Einstellung. Jedenfalls blieb die Forumseite angenehm bannerfrei, nachdem ich mich gerade einloggte. Aber warten wir ab, was die “Viereckigen Augen” dazu sagen.



  • @maroc sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    @mvsfsvm sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Es geht gar nicht um die Blockade der Benachrichtigung. Der orange Balken ist keine.

    Dem Fragesteller geht es doch wohl um beides, d.h. er möchte gerne den orangen Balken und die (eigentlichen) Benachrichtigungen unterbinden.

    Solange er im orangen Balken nicht auf den Link zum Aktivieren der Benachrichtigung klickt, gibts halt keine.

    Der FF merkt sich da gar nichts […]

    Offensichtlich hat mein FF ein besseres Gedächtnis als Deiner 🤤. Voraussetzung ist die oben beschriebene Firefox-Einstellung. Jedenfalls blieb die Forumseite angenehm bannerfrei, nachdem ich mich gerade einloggte. Aber warten wir ab, was die “Viereckigen Augen” dazu sagen.

    Die Einstellung ist nur für die Benachrichtigungen und nicht für den orangen Balken. Wenn du den dauerhaft nicht siehst, wird wohl dein Adblocker der Schuldige sein.



  • @mvsfsvm sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Die Einstellung ist nur für die Benachrichtigungen und nicht für den orangen Balken. Wenn du den dauerhaft nicht siehst, wird wohl dein Adblocker der Schuldige sein.

    Kaum. Ich habe einen Adblocker in Firefox und sehe keinen solchen Balken. Aber ich habe keinen Adblocker in Safari und auch keinen in Opera - und auch dort sehe ich keinen solchen Balken (MacOS X 10.13.6)…


  • Globaler Moderator

    @mac-christian
    Wollte gerade auch sagen, dass ich diesen Balken schon seit über zwei Jahre nicht mehr gesehen habe, musste dann aber feststellen, dass ich - da ich nicht kapiere, was unter Notifications zu verstehen ist - schon Ende 2017 eine Filterregel für uBlock Origin habe:
    forum.mediathekview.de##.visible-md-block.visible-lg-block.desktop-notification-permission

    Ich komme bestens ohne diese Notifications im Forum zurecht.



  • @MenchenSued das ist die Regel, die bei dir den orangen Balken blockt.



  • @maroc sagte: Nachtrag: Wobei, genau gesagt, beides blockiert wird: Anfragen und Benachrichtigungen …

    Ja, und bei anderen Usern trotz entsprechender Einstellung offenbar nicht:

    MV-Forum_Desktop-Notificatons_FF-Settings.png

    Und das Banner kommt von der Webseite, nicht vom Browser selbst:

    MV-Forum_Desktop-Notificatons_Code.png

    Und genau dieses Element, also das Banner wird bei mir seit Beginn mit einem Contentfilter geblockt (hat also wie von @mvsfsvm sinngemäss formuliert nichts mit den Browser-Einstellungen zu tun).
    Firefox bringt erst eine Interaktionsmöglichkeit, wenn man beim Banner auf "aktivieren"drückt:

    MV-Forum_Desktop-Notificatons_FF.png

    Erst damit merkt sich Firefox die Wahl, aber eben sie hat – zumindest bei gewissen Usern – keinen Einfluss auf das Anzeigen des Banners.

    Das Problem scheint mir eher auf die Forensoftware zurückzuführen sein. Die produziert auch sonst immer wieder mal Lustiges (mit dem obigen Problem verbunden):

    MV-Forum_Container_Nav.png

    Auch kommt bei mir immer wieder, aber nicht immer, die Meldung mit Hinweis auf eine Sitzungsdiskrepanz (manchmal zurecht, weil noch eine weitere Forumseite in einem zweiten Tab geladen war, meistens jedoch nicht):

    MV-Sitzungsdiskrepanz.png



  • Ich habe jetzt nochmal nachgeschaut, dieses orangene Banner wird bei mir in der Tat von den “Cosmetic Filters” in ublock weggeblockt und hat nichts mit den FF-Einstellungen bezüglich Notifications zu tun.

    forum.mediathekview.de##.visible-md-block.visible-lg-block.desktop-notification-permission
    

    Irgendwie wäre es schön wenn man dieses Zeug einfach direkt hier in seinen Forums-Einstellungen deaktivieren könnte…



  • @vitusson sagte in Frage zum Forum: Kann man die desktop notifications abstellen ?:

    Irgendwie wäre es schön wenn man dieses Zeug einfach direkt hier in seinen Forums-Einstellungen deaktivieren könnte…

    So ist es.


  • Administrator

    Benutzt die überhaupt jemand oder ist froh, dass er Notification darüber bekommt?



  • Whow, da hab ich ja was losgetreten …

    Aaaalso … die Notifications an sich habe ich erfolgreich geblockt. Die Anfragen um Erlaubnis wohl auch, denn der orangene Balken ist das einzig verbliebene, das noch irritiert.
    Meine FF-Einstellungen sehen in etwa so aus wie bei den geposteten Screenshots (nur dass ich die GUI-Sprache auf englisch habe)

    Abstellbarkeit im Forum wäre auch für mich die ideale Lösung.


Log in to reply
 

39
Online

4.3k
Users

3.7k
Topics

24.2k
Posts