Fehler mit Kodi 19 unter openSUSE Leap 15.1



  • Guten Morgen,

    ich habe kürzlich mein Kodi auf Version 19 angehoben. Seitdem bekomme ich folgenden Fehler:

    2020-01-03 08:18:07.919 T:3622   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                 - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                Error Type: <class 'SyntaxError'>
                                                Error Contents: invalid syntax (kodiaddon.py, line 41)
                                                Traceback (most recent call last):
                                                  File "/home/mediapc/.kodi/addons/plugin.video.mediathekview/service.py", line 29, in <module>
                                                    from resources.lib.service import MediathekViewService
                                                  File "/home/mediapc/.kodi/addons/plugin.video.mediathekview/resources/lib/service.py", line 12, in <module>
                                                    from resources.lib.kodi.kodiaddon import KodiService
                                                  File "/home/mediapc/.kodi/addons/plugin.video.mediathekview/resources/lib/kodi/kodiaddon.py", line 41
                                                    self.language = self.addon.getLocalizedString
                                                       ^
                                                SyntaxError: invalid syntax
                                                -->End of Python script error report<--
    

    Im Git gibt es zu dem Thema auch eine Meldung.

    Die Kodi-Version ist von hier und gegen Python 3.6 gebaut, falls das wichtig ist.



  • @nonamefound sagte in Fehler mit Kodi 19 unter openSUSE Leap 15.1:

    Python 3.6 gebaut

    Ich denke das der Code noch nicht an Python 3.6 angepasst ist. Wenn Du Kodi selbst compilierst mach es doch einfach gegen Python 2.7.
    Da @tuxpoldo letzter Kommentar auf Github schon wieder ein paar Wochen alt ist würde ich jetzt kein schnelles Update erwarten.



  • Hallo zusammen,

    danke für die Änderungen im GIT!
    Ich habe das aktuelle Repo geklont, die Datei addon.kodi19.xml in addon.xml umbenannt, gezippt und installiert. Funktioniert wieder einwandfrei mit Kodi 19.
    Auch das standalone update mit mvupate3 klappt wieder per Skript:

    [07:38:16 @ Do Mai 21]root@Rechenzwerg[~/]$cat /usr/local/bin/update_mediathekview_db.sh
    #! /bin/bash
    export PYTHONPATH="${PYTHONPATH}:/usr/lib/python3.6/site-packages/kodi"
    /var/lib/kodi/.kodi/addons/plugin.video.mediathekview/mvupdate3 mysql -v -uXXX -pXXX -HXXX -d XXX
    exit 0
    [07:59:13 @ Do Mai 21]root@Rechenzwerg[~/]$
    

    Mittlerweile läuft es hier unter openSUSE Leap 15.2.



  • Ah ok, hatte ich gar nicht gelesen: Release
    Danke, die Version 0.6.3 läuft einwandfrei!.


Log in to reply
 

34
Online

4.1k
Users

3.4k
Topics

22.2k
Posts