MV 13.1.0 Startproblem



  • MV 13.1.0 habe ich gestern geladen (DMG für Mac). Da ich mir die “alte” Version 13.0.6 nicht gleich überschreiben wollte, habe ich das Programm zuerst auf den Schreibtisch gezogen und umbenannt in MediathekView2, erst dann in den Programmordner und auf dem MacBook gestartet.

    Die Lüfter drehten hoch, und dann passierte wohl eine ganze Weile nichts. Ich hatte das MacBook dann vergessen und bin ins Bett gegangen. Heute früh war das Laden der neuen Filmliste noch immer nicht fertig (jedenfalls gemäss Anzeige) und nichts passiete mehr. Ich wollte MV dann abschiessen (mit Befehl - Option - Escape), MediathekView wurde aber nicht angezeigt, dafür ein Prozess “Main”, den ich dann abgeschossen habe. Und siehe da, MV wurde beendet.

    Liegt der Fehler darin, dass ich das Programm umbenannt hatte, oder ist da noch was anderes nicht so, wie es sein sollte?

    MacBook Pro 13" Late 2011 mit Intel Core i7 2,8 GHz, 8 GB RAM, MacOS High Sierra 10.13.6


  • Administrator

    Benenn mal den .mediathek3 Ordner um und versuche das Programm mit standard Einstellungen zu starten.



  • Dass das Programm Main heisst, hat nichts mit Deiner Umbenennung zu tun, das ist bei mir in der neuen Version auch



  • @nicklas2751 sagte: Benenn mal den .mediathek3 Ordner um und versuche das Programm mit standard Einstellungen zu starten.

    Das bringt zumindest – zum aktuellen Zeitpunkt – nichts. Hatte das eben versucht, nachdem das Problem wie von @mac-christian beschrieben erneut aufgetreten war (ich hab das ja schon gestern beschrieben).

    Das Log-File wächst und wächst, solange man den Prozess nicht killt und die CPU-Kerne werden mächtig belastet:

    0_1532677956621_MV_13.1_CPU-Belastung.png

    .

    0_1532677864328_MV_13.1_Log-File-Groesse.png



  • Hab jetzt zwei Dateien im Cache-Verzeichnis (~/Library/Caches/MediathekView) gelöscht, jetzt klappt’s wieder:

    0_1532678897982_Caches_DB-Files.png


  • Entwickler

    Wenn das Log File so gross wird bitte Mal reinschauen welche Fehler dort kommen bzw irgendwo für mich verfügbar machen. Ansonsten muss ich raten was es sein könnte und das hilft nicht. Genau deshalb wurde das neue Log integriert.



  • @derreisende77 sagte: Wenn das Log File so gross wird bitte Mal reinschauen welche Fehler dort kommen bzw irgendwo für mich verfügbar machen.

    Hab kurz reingeschaut, deshalb bin ich überhaupt auf die Idee mit dem Löschen der db-Files gekommen. Via Chat ein komplettes Log-File.



  • Die beiden Dateien, die styroll erwähnt (mediathekview.mv.db und mediathekview.trace.db) waren bei mir nicht da. Aber ich habe den Mac abends runtergefahren und am nächsten Morgen hats dann funktioniert. MV 13.1.0 läuft jetzt problemlos neben 13.0.6 auf dem gleichen Gerät. Keine Ahnung, was der Grund für die “Selbstheilung” war.

    Nur: 13.1.0 braucht länger, bis es einsatzbereit ist als die alte Version (wenn keine Filmliste geladen werden muss). Wenn jetzt noch die Filterprofile wieder kommen, kann ich die alte Version getrost entsorgen… 🙂



  • Das Problem habe ich auch (macOS High Sierra), MV 13.1.0 hängt beim Download der Programmliste und kann nur durch “Sofort abbrechen” beendet werden. Nach Neustart des Rechners lädt die Programmliste neu (aber langsamer als in der früheren Version). Das Löschen der o.g. Library-Dateien hilft nicht.
    Aber schön, dass ihr das Programm weiterentwickelt! Danke!



  • Hallo,

    ich habe zwar Win7 64 aber das Problem mit dem Laden der Filmliste hatte ich auch.
    Ich habe dann die Speicherzuweisung für Java auf “-Xms512M -Xmx2G” angehoben.
    Danach läuft die neue Version schneller als die alte und ohne Absturz.

    Holger


  • Entwickler

    @hubato was für einen Mac hast du? Es kann sein das zum Zeitpunkt Abos filtern das Programm aussieht das es hängt. Das kann je nach aboliste schon Mal 30 Sekunden dauern.



  • @derreisende77
    einen älteren MB Pro. Das “Hängen” dauert schon mal mehrere Stunden. Ich benutze jetzt wieder die vorige Version, weil es damit keine Probleme gibt. Nach dem nächsten Update versuche ich es nochmal



  • Ich habe das selbe Problem, dass sich das Programm beim Laden der Filmliste aufhängt. Läuft unter Ubuntu 18.04, 64 Bit. Das Löschen des Verzeichnisses .mediathek3 und die Änderung der Speicherzuweisung, wie oben vorgeschlagen, hat leider nicht geholfen.


 

72
Online

2.4k
Benutzer

2.0k
Themen

12.3k
Beiträge