Mediathekview schreibt laufend in .xsession-errors



  • Ich denke, die Ursache ist geklärt, da brauche ich keinen neuen user anzulegen oder Versuche mmit anderen WM anzustellen:

    1. MV schreibt laufend und im Sekundentakt in STDOUT. Die Ursache dafür ist MV.
      Einen sachlichen Grund für dieses Verhalten kann ich nicht erkennen. Wer benötigt im Normalbetrieb einer GUI-Anwendung ASCII-Grafiken auf STDOUT? Oder sekündliche Erfolgsmeldungen?

    2. XFCE leitet STDOUT nach .xsession-errors um, jedenfalls in meiner Distro. Die Ursache dafür ist die Konfiguration von XFCE. Und diese Konfiguration ist prinzipiell richtig, denn wenn man bei einer Anwendung den Debug-Modus anmacht, möchte man diese Ausgaben im Log haben, dafür ist das Log da.

    3. Andere WM leiten STDOUT anscheinend nach /dev/null, um dem Problem übermäßig geschwätziger Anwendungen entgegenzuwirken. Das ist eine Krücke.

    Aus meiner Sicht richtiger Ansatz, um das Problem zu lösen: MV nur noch das Nötigste mitteilen lassen.
    Ehrlich, im Sekundentakt - das kann doch für niemanden sinnvoll sein.



  • Okay, ich dann dann raus. Du hast offenkundig absolut kein Interesse das Problem zu analysieren, da deine Schlussfolgerung sowieso schon feststeht. Kann man machen, dann soll man sich aber nicht wundern wenn man nicht weiterkommt.



  • @kaimon Dann konfiguriere dir das weg: __system-parameter__dl_progress_ von true auf false in der mediathek.xml.


  • Administrator

    @kaimon sagte in Mediathekview schreibt laufend in .xsession-errors:

    Aus meiner Sicht richtiger Ansatz, um das Problem zu lösen: MV nur noch das Nötigste mitteilen lassen.
    Ehrlich, im Sekundentakt - das kann doch für niemanden sinnvoll sein.

    Fakt ist zum aktuellen Zeitpunkt können wir das nicht so schnell ändern.
    Da MediathekView so programmiert wurde dass die Logausgaben alle selber gebaut wurden anstatt einen Logger zu nutzen kann man nicht so mal eben das umbauen.
    Aber da du ein Linux nutzt kannst du eventuell die ausgaben erzwungenermaßen nach /dev/null umleiten?
    also java -jar MediathekView.jar > /dev/null
    Oder ignoriert dass dein Windowmanager und klemmt sich dazwischen?

    Da MediathekView irgendwann in der Zukunft größere Änderungen erfährt wird da auch in dem Zuge ein Logging mit Logger eingebaut, dann kann man das Loglevel beeinflussen.



  • @vitusson: … und tschüß.

    @georg-j: super, auf so einen Vorschlag hab ich gehofft - das schaue ich mir genauer an.

    @alex: Dafür hab ich volles Verständnis. Danke, daß Du planst, das Problem aufzugreifen. Und den Startparameter werde ich auch ausprobieren.

    Ich bin übers WE weg, aber ich melde mich wieder mit den “Versuchsergebnissen”.



  • @alex: java -jar MediathekView.jar > /dev/null führt, wenn ich das richtig interpretiere, dazu, daß MV versucht /dev/null als Arbeitsverzeichnis zu benutzen. Meine Konf wird dann nicht mehr gefunden.
    @Georg-J: Das scheint zu funktionieren. Super, vielen Dank!



  • @alex: Ich muß mich korrigieren, ~/> wird als Arbeitsverzeichnis angelegt, der Rest wird ignoriert. Ich starte MV allerdings nicht aus dem Terminal, sondern mit einem Starter und da geht der Parameter offensichtlich nicht.

    Den XFCE-Usern zuliebe könntet Ihr vielleicht überlegen, den von Georg genannten Parameter per default auf “false” zu setzen. Allen anderen schadet das nicht, die loggen eh nach /dev/null. Und wer debuggen will, kann das ja einfach wieder auf “true” setzen.

    Oder jedenfalls einen Tipp in der Hilfe?


Log in to reply
 

87
Online

3.1k
Users

2.5k
Topics

15.4k
Posts