neue Version 13.6 startet nicht wegen "nicht genügend Arbeitsspeicher"


  • Hallo
    bei der Version 13.6. erhalte ich die Fehlermeldung von Mediathekview “nicht genügend Arbeitsspeicher”, startet nicht. Und das auf meinen beiden Rechnern, beide Win10, 64 bit, alles up to date. Genügend Arbeitsspeicher ist auch vorhanden, 4 GB bzw. 8 GB. Die Vorgängerversion 13.5.1 läuft auf beiden einwandfrei.
    Die Desktopheapbegrenzung hatte ich auch schon vergrößert, kein Erfolg.
    Irgendwelche Tipps/Hinweise ?
    viele Grüße


  • @wsa
    Welche Version hast du denn verwendet, die EXE oder die ZIP-Version, und mit welcher Datei hast du Mediathekview gestartet?


  • Hallo
    die Meldung kommt bei beiden Versionen .exe und .zip (verwende ich normalerweise). Startversuche immer mit mediathekview.exe. Irgendwo fand ich den Hinweis mit .jar zu starten, da findet mein Rechner kein passendes Programm dazu.

  • Globaler Moderator

    @wsa
    Mach mal im Verzeichnis von MediathekView ein CMD-Fenster auf und tipp ein: jre/bin/java --enable-preview -jar MediathekView.jar


  • Hallo
    Fehlermeldung: “der Befehl “jre” ist entweder falsch geschrieben oder konnte nicht gefunden werden”
    viele Grüße

  • Globaler Moderator

    @wsa
    Sorry, war gedanklich in Linux unterwegs.

    Such mal das Programm java.exe im Pfad jre\bin unterhalb des Mediathek-Verzeichnisses. Dann gehe zu dem Verzeichnis vom MediathekView.jar und rufe es mit

    jre\bin\java --enable-preview -jar MediathekView.jar
    

    auf. jre\bin\java sollte die java.exe Version 14 starten. Funktioniert das, kannst Du mit den Speicherparametern -Xmx und -Xms spielen


  • Hallo,
    und ja, java.exe ist dort vorhanden.
    den Aufruf hatte ich im cmd-Fenster ja schon gemacht, Egebnis siehe weiter oben, Fehlermeldung.
    Dann noch den Befehl in eine Batch-Datei und im Verzeichnis gestartet, Ergebnis: keine Reaktion, auch keine Fehlermeldung.


  • @wsa Hast du auch “/” durch “\” ersetzt?

  • Globaler Moderator

    This post is deleted!

  • ups, natürlich nicht …

    cmd_Fenster kommt mit: "picked up _java_options: -Xmx512M
    danach die Mediathekview Meldung “nicht genügend Arbeitsspeicher”


  • @wsa Dann setz mal -Xmx2G in die Zeile

  • Globaler Moderator

    @wsa
    Na, da hast Du es ja schon. 512MByte sind zu wenig. Da braucht’s mindestens 1G. Hast Du das in einer vmoptions Datei stehen? Füg mal probeweise -XMx1G in Deiner befehlszeile vor -jar dazu. Statt 1G kannst Du auch 2G nehmen.

    jre\bin\java --enable-preview -Xmx1G -jar MediathekView.jar
    

  • @MenchenSued
    ich habe in der Befehlszeile gleich 2G eingesetzt, im aufgehenden cmd-Fenster erscheint aber diegleiche Meldung wie oben “picked up _java_options: -Xmx512M” und danach die Mediathekview-Fehlermeldung.

    Datei mediathek.vmoptions:

    # Enter one VM parameter per line
    # For example, to adjust the maximum memory usage to 512 MB, uncomment the following line:
    # -Xmx512m
    # To include another file, uncomment the following line:
    # -include-options [path to other .vmoption file]
    

  • vor den Zeilen der .vmoptions steht jeweils ein #; wurde hier plötzlich ausgeblendet


  • noch zur Info: mit der obigen Befehlszeile funktioniert die alte Version 13.5.1 wie vorher, einwandfrei.


  • @wsa _java_options ist irgendwie in dein Environment geraten, sieh z. B. Stackoverflow.

    Teste das bitte mit

    echo %_JAVA_OPTIONS%
    

    Wenn da nichts rauskommt, wird’s schwierig, falls es
    -Xmx512M
    ergibt, probier mal

    set _JAVA_OPTIONS=
    

    und dann deinen Java-Start. Wenn das hilft, musst du nur noch suchen, wo es herkommt…


  • @wsa sagte: Datei mediathek.vmoptions:

    Genau bei dieser Datei im MV-Programmverzeichnis kannst du die 3. Zeile editieren (z.B. “-Xmx1.5G”) und die Speicherzugabe anpassen und das “#” nur bei dieser Zeile entfernen. Dann kannst du MV normal mit der Exe starten.

    Java ist im MV-Programmpaket schon drin und wird via Exe auch verwendet. Du brauchst da vorerst nicht auf die Kommandozeile zu gehen, schon gar nicht mit Linux-Syntax…

    Wenn das nicht klappt, hilft dir vielleicht dieser Thread.


  • @styroll
    habe ich probiert:
    mit Xmx1G kommt wieder die Meldung “nicht genügend Arbeitsspeicher”
    mit Xmx1.1G und größer kommt: “die JVM konnte nicht gestartet werden. Die maximale Heapgröße (-Xmx) könnte zu groß sein oder ein Antivirustool könnte die Ausführung blockieren”

    Den Windows Defender abschalten hat auch nichts gebracht.

    Jetzt weiß ich auch nichts mehr, da gleiches Verhalten an beiden Rechnern und kein Problem mit der Vorgängerversion, also werde ich wohl bei 13.5.1 bleiben müssen.

    danke erst Mal an alle


  • @jkrieger
    Halleluja, es läuft.
    Beim Link Stackoverflow werden auch die Umgebungsvariablen angesprochen, und genau da fand ich den Eintrag “_Java_options -Xmx512M”, der offenbar alles andere immer überschrieben hat. Woher der Eintrag kam, keine Ahnung. War auf beiden Rechnern (da laufen auch überwiegend die gleichen Programme). Eintrag gelöscht, 13.6 läuft.

    herzlichen Dank an alle nochmal


  • @wsa sagte: werden auch die Umgebungsvariablen angesprochen, und genau da fand ich den Eintrag “_Java_options -Xmx512M”, der offenbar alles andere immer überschrieben hat. […] Eintrag gelöscht, 13.6 läuft.

    Könntest du für andere User erklären, wo und wie du den Eintrag sichtbar gemacht und dann gelöscht hast? Danke.

    Und ich nehme an, dass du jetzt 13.6 normal über einen Doppelklick auf die Exe-Datei öffnest?

37
Online

4.4k
Users

3.8k
Topics

24.8k
Posts