Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!



  • Mediathek View funzt nur sehr eingeschränkt und das liegt nicht an meiner Leitung (50 -70 Mbit aber immer).
    Es frisst nur CPU (55 Prozent) und Arbeitsspeicher (1,1GB).
    Auf Mausbefehle keine oder nur sehr späte Reaktion (ca. 10 - 20 Minuten).
    Braucht ca. 6 Minuten zum Liste laden bei permanenten 50 MBit im WEB.
    Durch die Liste kann ich nicht scrollen.
    Muss mich sehr sehr umständlich zu dem gesuchten Film mit den kleinen Pfeiltasten am rechten
    Rand durch die Liste bewegen. Auch wenn ich in der Nähe der Buchstaben bin, die ich suche,
    dauert es nach dem Start des Programms bis zum TATSÄCHLICHEN FILMSTART ca 30 Minuten,
    bis ich den Film sehen kann.
    Also wenn der Film in der Liste ,die ja sehr lang ist,
    endlich angezeigt wird, gehts schnell.
    Aber vorher hängt sich das neue Programm von euch immer wieder auf.
    Die alte Softwareversion lief besser.
    Vielleicht liegt es auch am MS-UPDATE dieser Woche, denn vor 2 Monaten war die alte Version lauffähig.
    Also definitv ein Unterschied.
    Heisst für mich: vor dem Abendbrot das Programm starten und nach dem
    Kochen, Essen und Abwasch mal schauen ob s den läuft…



  • @Funktioniertnicht sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    Braucht ca. 6 Minuten zum Liste laden bei permanenten 50 MBit im WEB.

    Kann nicht sein, bei 50 Mbit/s wäre die Liste in etwa 6 s geladen. Die Liste ist nur etwa 36 MB groß und nicht über 2 GB.

    Außerdem wären Angaben zur genutzten Hard- und Software hilfreich, insbesondere auch die Version von Mediathekview .



  • Hallo,ich habe 100 Mbit und mir geht es genauso. Gibt man in die Suche etwas ein bleibt schon nach dem ersten Buchstaben alles stehen und es dauert eine weile bis die nächsten Buchstaben das Wort vervollständigen.



  • Mein Laptop ist brand neu und teuer (€1200), Internet 100MB, Windows-10 Vers 1903.
    Trotzdem MV reagiert sehr langsam (beim Suchen).
    Kochen & Abwasch … macht meine Frau 😉
    Schuld ist MS … ??



  • Hmmm, ich hab grad ein Déjà-vu. DIe 13.2.1 stand in der Kritik, weil sie im Vergleich zu den Vorgängerversionen so langsam war. Da wurde empfohlen, auf ältere Versionen zurück zu gehen.

    Wiederholt sich die Geschichte?

    BTW: Wenn MV beim Suchen langsam reagiert, ist (IMHO) die Internetgeschwidigkeit wurscht, da sollte die Filmliste schon da sein, und es nur mehr ein “lokales” Thema zu sein.


  • Administrator

    In die Jahre gekommener Intel® Core™ i5-2500 CPU, 24 GB Ram, Nvidia Geforce GTX 970, Windows 10 und Pop OS 19.10 und bei mir startet es innerhalb von Sekunden, Filmliste ist nach weiteren wenigen Sekunden geladen. Die normale, nicht Volltext, suche läuft schnell. Volltextsuche läuft ok. Alles also nicht mehr ganz aktuell und läuft trotzdem problemfrei.

    Schaut euch mal im Taskmanager an was bei eurem Programmstart am meisten ausgelastet wird und vor allem welche anderen Programme ggf. noch Ziehen. Oft startet man MV ja direkt nach dem Systemstart, da starten sich jedoch auch meist andere Programme die ordentlich an der Leistung ziehen wie z.B. Virenscanner und andere Hintergrundprogramme.



  • Komisch, hier nennt niemand seine MV-Version, trotz Hinweis.

    Hier läuft noch 13.2.1 und die Suche ist auf dem, mindestens 4 Jahre altem Rechner trotzdem noch Ok. Nur die Volltextsuche (benutze ich in der Regel nicht) ist so ziemlich zäh. Ach ja, ich erweitere die lokale Filmliste immer eine ganze Weile statt sie zu ersetzen. Das wirk sich auch negativ auf die Suche aus. Es ist nämlich schon ein Unterschied ob nur rund 300.000 oder aber knapp 1 Million Einträge durchsucht werden müssen.


  • Administrator

    @mvsfsvm sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    MV-Version, trotz Hinweis

    Stimmt, in meinem Fall die 13.5.1



  • Den Effekt dieser extremen Trägheit trotz flottem I7-System kenne ich auch.

    Und zwar wenn man die Gesamtliste nach gewissen Spalten wie “Dauer” sortiert, dann bricht die Performance extrem ein, ziemlich wie hier vom OP geschildert.

    Normalerweise sortiert man die Gesamtliste ja nie nach Dauer. Aber wenn ich z.B. die Trefferliste einer Suche nach “Dauer” sortiert hatte und dann das Programm geschlossen habe, dann erwischt einen der Mist beim nächsten Start mit der Gesamtliste. Dann heißt es minutenlang warten, bis MediathekView auf die Auswahl einer performanteren Spalte wie “Zeit” reagiert und sich das ganze wieder einrenkt.


  • Globaler Moderator

    @Purche sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    Dann heißt es minutenlang warten, bis MediathekView auf die Auswahl einer performanteren Spalte wie “Zeit” reagiert und sich das ganze wieder einrenkt.

    Minutenlang habe ich bei MV noch nie auf irgendetwas warten müssen.
    Aufgrund dieses Themas habe ich heute morgen die Zeiten gestoppt.
    Allererster Start des Tages MV, 38 Sekunden bis Programm betriebsbereit.
    Nächster Start 12 Sekunden bis zur Bedienbarkeit des Programms. Länge der Filmliste 336xxx Einträge.
    Version 13.5.1 - W 10/64 - FFTH aktuell 289 Mbps



  • @iks-jott sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    @Purche sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    Dann heißt es minutenlang warten, bis MediathekView auf die Auswahl einer performanteren Spalte wie “Zeit” reagiert und sich das ganze wieder einrenkt.

    Minutenlang habe ich bei MV noch nie auf irgendetwas warten müssen.
    Aufgrund dieses Themas habe ich heute morgen die Zeiten gestoppt.
    Allererster Start des Tages MV, 38 Sekunden bis Programm betriebsbereit.
    Nächster Start 12 Sekunden bis zur Bedienbarkeit des Programms. Länge der Filmliste 336xxx Einträge.
    Version 13.5.1 - W 10/64 - FFTH aktuell 289 Mbps

    Dann mach dasselbe nochmal, nachdem Du die Sortierung auf “Dauer” gestellt hast…


  • Globaler Moderator

    @Purche
    Unter Linux kann ich nach allen Spalten sortieren und muss nur ein paar Sekunden warten. Warum sollte Windows da länger brauchen, die Spalten enthalten doch nur Daten, mal Zahlen und mal Text. Ich würde eher auf Virenscanner, Speicherausbau oder Java-Version tippen.



  • Mein Beitrag zur Performance-Statistik:

    (auf Lenovo i5 8GB mit Win7 Pro - jaja …)

    Version 13.0.6

    Hochfahren war nie ein Problem (ich lade allerdings eine neue Filmliste immer separat herunter und ziehe sie dann von der lokalen Festplatte aus ein; hat sich so eingebürgert als ich mal Probleme mit “… nicht geklappt” hatte, und hat sich bewährt.)

    Meine Darstellung ist standardmäßig “nach Datum” - (einziges Problem ist gelegentlich die Flut vom BR, wenn ich mal wieder die falsche Stunde erwischt habe) - Und Wiederholungen finde ich immer beim Datum der Originalausstrahlung. Soweit alles dokumentiertes und gut verstandenes Verhalten.

    Zur Diskussion um die Verzögerungen:

    Wenn ich einen Suchbegriff eintippe, wird regelmäßig zunächst nur der erste Buchstabe angezeigt, dann holt das Programm erstmal tief Luft und zeigt mir den Rest des Suchbegriffs und die entsprechend gefilterte Liste an. Änderungen an dem Suchbegriff gehen dann flott von der Hand.

    Schlußfolgerung: Das Durchsuchen einer sortierten Liste von gut 340000 Einträgen dauert einige Sekunden, auch bei meiner älteren und ansonsten sehr gut beleumundeten Version. Das scheint mir auch gerechtfertigt, wenn man bedenkt, daß das alles in einer 3GL programmiert wurde und vermutlich nicht bis ins Letzte auf Performance in diesem speziellen Anwendungsfall getunt wurde,

    Interessant ist, daß das in den neueren Versionen anscheinend signifikant länger braucht. Nun können wir spekulieren, woran das liegt. Wenn die Entwickler den teil nicht sehr gründlich neu gestaltet haben (und warum sollten sie?) dann bleiben externe Einflüsse: Sind neuere JVMs langsamer? Funktioniert womöglich die JIT-Kompilation nicht mehr? Tiefere Einblicke benötigen mehr Kenntnisse im Umgang mit Java als die meinigen.



  • @MenchenSued sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    @Purche
    Unter Linux kann ich nach allen Spalten sortieren und muss nur ein paar Sekunden warten. Warum sollte Windows da länger brauchen, die Spalten enthalten doch nur Daten, mal Zahlen und mal Text. Ich würde eher auf Virenscanner, Speicherausbau oder Java-Version tippen.

    Dass die Sortierung bei der 13.5.1. (frische Installation) unter Win unterschiedlich lange dauert, je nach dem welches Feld man als Sortierkriterium verwendet, kann ich hier bestätigen.

    Sortierung nach der Nummer geht fast ohne Verzögerung.

    Wenn ich die Sortierung nach Sendern als Messlatte nehme (Voraussetzung: zuerst nach Nummer sortiert), dann habe ich in etwa folgende Relationen:

    • Thema: Faktor 4 - 10 (je nach dem welche Spalte vorher sortiert war)
    • Titel und Dauer: ca. Faktor 20 - 25

    In der Zeit in der sortiert wird, ist MV tatsächlich “scheintot”, nicht einmal das Alter der Filmliste wird hochgezählt.

    Und das ganz mit 32 GB RAM / i5-4570 @3.20 GHz / Win 10 Pro 64bit.


  • Entwickler

    @DaDirnbocher das ist nachvollziehbar. Je länger der Text ist der verglichen werden muss desto länger dauert das ganze. Und Titel Thema sind sehr lange Texte.
    Der Arbeitsspeicher ist in dein Fall keine Hilfe da das Programm ja auf 1gb limitiert ist. Ggf kannst du Mal testen wie es aussieht wenn du dem Programm maximal 4gb zugestehst. Das sollte das ganze auch beschleunigen.


  • Globaler Moderator

    @Purche sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    Dann mach dasselbe nochmal, nachdem Du die Sortierung auf “Dauer” gestellt hast…

    @Purche

    Sortierung nach Dauer
    Erster Start des Tages 1:58 Minuten bis Bedienbarkeit, weitere Starts 1:34 Minuten bis Bedienbarkeit MV.
    OK, das ist schon ein Unterschied, aber weit entfernt von dem, was der TE schildert.
    Ich starte in der Regel mir sortierten Sendern.
    Gruß


  • Globaler Moderator

    @iks-jott : Hast Du die Windows Patches von letzter Woche schon eingespielt?

    Beim letzten Microsoft Patch berichten einige User von massiven Einbruch bei der WLAN Performance sowie einige andere nicht erklärbare Effekte. Abhilfe hat die Deinstallation gebracht, ist aber sicherlich keine Lösung. Ansonsten könnte es auch helfen, testweise mit einem frischen Profil anzufangen, denn möglicherweise haben die Problem-User auch ganz spezielle Profile, beispielsweise extensive Blacklists oder massenweise Abos, die den Start so in die Länge ziehen.



  • Also, der Tipp mit der Sortierung ist schon mal super. Hatte mich bereits daran gewöhnt, dass ich erst mal 1-2 Minuten warten muss. Das ist auch schon länger bzw. immer so. Bei mir war es nach Sendern sortiert.

    Meine absoluten Zeiten dürften nicht repräsentativ sein, weil es auf einem relativ sparsamen Windows Server läuft. Aber was bei mir (ohne Download der Filmliste) am längsten dauert (ungefähr 2/3 der Startzeit), ist das Eintragen der Abos. Aktuell sind es 38, 31 davon aktiv.


  • Globaler Moderator

    @MenchenSued sagte in Programm verbraucht viel Arbeitsspeicher und Strom bis es nach 20 Minuten läuft!!!:

    @iks-jott : Hast Du die Windows Patches von letzter Woche schon eingespielt?

    @MenchenSued

    Danke für den Hinweis.
    Gruß



  • This post is deleted!

Log in to reply
 

115
Online

4.1k
Users

3.4k
Topics

22.2k
Posts