"fehlerhaft" ist nicht gerade hilfreich



  • Hallo
    Ich versuche von ORF bestimmte Videos runterzuladen. Nach ca. 2 sek. erscheint die Meldung “fehlerhaft”. Leider ist das nicht sehr hilfreich, um den Grund des Fehlers zu eruieren.
    im Mediathekview.log findet sich ausser “[Download ist fertig und war fehlerhaft, …” auch nichts Gescheites. Gibt es noch anderswo etwas hilfreichere Informationen (z.B. Zugriff verweigert, oder URL ungültig, oder Seite nicht gefunden, etc)?
    Danke



  • @Wodan51 Probiere das.

    Ansonsten hast Du im Logfile den aufruf vom ffmpeg, den könntest an der konsole manuell starten, dan siehst die fehlermeldung vom ffmpeg.



  • @DaDirnbocher Danke
    Habe nun ein anderes Problem: Das log-file ist weg. D.h. es ist eines da, aber von heute. Es scheint, dass das immer wieder überschrieben wird. So habe ich natürlich keinen Zugriff mehr auf ältere Logs.



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    Habe nun ein anderes Problem: Das log-file ist weg. D.h. es ist eines da, aber von heute. Es scheint, dass das immer wieder überschrieben wird. So habe ich natürlich keinen Zugriff mehr auf ältere Logs.

    Ist ja eigentlich eh egal. Denn es gibt 2 Möglichkeiten:

    a) Das Problem tritt nicht mehr auf, dann brauchst das alte Logfile nimmer, und kannst Dich freuen, dass es nun klappt.

    b) Das Problem tritt immer noch auf, dann hast eh einen Eintrag im aktuellen Logfile, den Du verwenden kannst.



  • @DaDirnbocher Fall b), habe den Download neu gestartet—>gleicher Fehler

    Download Fehler ORF.txt



  • @Wodan51 Aus Deinem Log:

    Programmaufruf: bin\ffmpeg.exe -i https://apas

    Da fehlt der user_agent-Eintrag, siehe hier, wobei Du allerdings auch die neueren Entwicklungen siehe hier beachten solltest.



  • @DaDirnbocher Ich laufe ja nicht in einem Browser. Mein user_agent ist “MediathekView”

    Einstellungen Mediathekview.jpg



  • Für den Download ist nicht dieser Eintrag zuständig, sondern der in “Set bearbeiten -> … speichern -> Hilfsprogramme -> ffmpeg”. Dort musst du eintragen, was ffmpeg dem Server erzählt, wer/was es sei. Siehe auch Bild im Anhang. Bei mir funktionierts (noch) mit nur “Mozilla” drin - aber wer weiss, wie lange noch.

    Dort, wo bei dir jetzt “MediathekView” stehst, darfst du aber auch etwas Unverfänglicheres eintragen. Bei mir steht dort:

    Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:62.0) Gecko/20100101 Firefox/62.0

    Bildschirmfoto 2020-02-21 um 18.27.53.jpg



  • @mac-christian Geht alles nicht. Ich fahre auf Windoof 10, nicht Mac wie du. Jedenfalls ist bin\ffmpeg.exe im MediathekView Verzeichnis.

    MediathekView Set.jpg



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    @mac-christian Geht alles nicht. Ich fahre auf Windoof 10, nicht Mac wie du. Jedenfalls ist bin\ffmpeg.exe im MediathekView Verzeichnis.

    MediathekView Set.jpg

    Schreib in der Zeile wo Schalter steht, nach dem a von Mozilla einen 2er. Also dass dann “Mozilla2” steht.



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    @mac-christian Geht alles nicht. Ich fahre auf Windoof 10, nicht Mac wie du. Jedenfalls ist bin\ffmpeg.exe im MediathekView Verzeichnis.

    Ja und? Ich dachte, es geht um den “user-agent”-Eintrag? Ich hatte nie behauptet, du solltest etwas an dem Eintrag ändern, wo bei dir auf ffmpeg verwiesen wird. Ich hab extra noch einen Pfeil ins Bild gemalt, damit du weisst, wo du was ändern sollst.

    Der Eintrag “Mozilla” funktioniert offenbar bei Windows-Installationen nicht mehr. Bei mir (mit macOS 10.13) aber schon.



  • @mac-christian @DaDirnbocher So, meine Herren. Habe nun alles befolgt, was ihr mir empfohlen habt (notabene: der Eintrag bin\ffmpeg.exe war schon immer da und nicht neu eingefügt).
    Neu ist jetzt der Eintrag mozilla2
    MediathekView Set 2.jpg Im weiteren sieht der Log nun so aus
    MediathekView Log.jpg Erstaunlich ist, dass im ersten File (SRF) der user_agent herangezogen wird, im zweiten (ORF) jedoch nicht.
    Hier das Logfile als txt.
    MediathekView Log (Auszug).txt
    Im weiteren habe ich die https-Einträge kopiert und direkt in Firefox gestartet. Beim ersten (SRF) habe ich jeweils 10-sekündige Segmente erhalten und ansehen können.
    Beim zweiten (ORF) krieg ich die Meldung, dass die Playlist (m3u8) nicht gefunden werden konnte.
    MediathekView m3u8 Datei nicht gefunden.jpg Äusserst seltsam; ich geb’s nun mal auf.
    Danke euch und wünsche noch ein schönes Wochenende.



  • @Wodan51 Der erste Download ist nach der Änderung zur Downloadliste hinzugefügt worden, der zweite davor.



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    @mac-christian @DaDirnbocher So, meine Herren. Habe nun alles befolgt, was ihr mir empfohlen habt (notabene: der Eintrag bin\ffmpeg.exe war schon immer da und nicht neu eingefügt).

    Kannst du mir mal bitte verraten, weshalb du so stur immer wieder auf dem Eintrag “bin\ffmpeg.exe” rumreitest? Niemand hat je gesagt, du müsstest den ändern oder irgendwas Ähnliches.

    Es ging immer einzig und allein um die Zeile, wo der user-agent drin steht.

    Und wenn du an einem Download die Einstellungen änderst, musst du ihn löschen und neu anlegen. Auch das hat schon irgendjemand hier beschrieben.

    Ich bin hier raus.



  • Tja @mac-christian, leider benimmst du dich nicht so, wie wir es von einem gepflegten Mitteleuropäer erwarten. Deshalb ist es gut, wenn du nun raus bist!
    Die Sache mit dem ffmpeg habe ich nur beiläufig erwähnt, rein informativ. Aber wenn du geistig nicht fähig bist, diese Aussage richtig einzuordnen, dann mach mir bitte deswegen keine Vorwürfe.
    Leider ist deine Aussage beim user_agent Mozilla ebenso falsch, da nur Mozilla2** (oder vielleicht würde auch gaga43 gehen) funktioniert.
    @DaDirnbocher Es scheint nun zu funktionieren, allerdings nur für Downloads, die nach der Einstellungsänderung im Downloadbereich erfasst wurden. Leider ist da die Hilfeseite von MediathekView nicht so ganz transparent und klar.



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    @DaDirnbocher Es scheint nun zu funktionieren, allerdings nur für Downloads, die nach der Einstellungsänderung im Downloadbereich erfasst wurden.

    Mannomann. Ich habe Dir heute folgendes empfohlen:

    8ee6e0d2-e42e-4460-a3e4-656851f281f8-image.png

    Und dort steht:

    2601c69a-f864-4fa1-bcc0-dfd33099db3c-image.png



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    Habe nun alles befolgt, was ihr mir empfohlen habt

    Nein, hast Du nicht.



  • @DaDirnbocher Hab ich nicht?? na, was denn? Läuft ja jetzt. Habe alle Downloads gelöscht, aber konnte sie nicht wieder erstellen, weil Downloadliste aktualisieren nicht ging.
    Habe dann einen neuen .mediathekview Ordner angelegt und die settings.xml und mediathek.xml kopiert. Nun geht’s.



  • @Wodan51 sagte in "fehlerhaft" ist nicht gerade hilfreich:

    Habe alle Downloads gelöscht, aber konnte sie nicht wieder erstellen, weil Downloadliste aktualisieren nicht ging.

    Natürlich nicht, denn gelöschte Downloads bekommst du so nicht wieder. Bei Downloads aus Abos hätte das funktioniert, sofern du die nicht gelöscht hättest und die Downloads nicht gestartet waren. Wer auf Nummer sicher geht, startet MV nach der Änderung neu.

    Bei manuell zur Downloadliste hinzugefügten Downloads kommst du um das erneute manuelle Hinzufügen nicht drumherum.


  • Globaler Moderator

    @mvsfsvm sagte in "fehlerhaft" ist nicht gerade hilfreich:

    Bei manuell zur Downloadliste hinzugefügten Downloads kommst du um das erneute manuelle Hinzufügen nicht drumherum.

    Eigentlich sollte so etwas nicht passieren, denn manuell hinzu gefügte Downloads werden in mediathek.xml (<!–Downloads–>) gespeichert und sind beim nächsten Aufruf wieder da. Sie werden erst entfernt, wenn der Download erfolgreich beendet wurde. Abos brauchen nicht gespeichert zu werden, da die Aktualisierung beim Start alle noch existierenden Treffer wieder im Downloads-Tab einträgt.


Log in to reply
 

31
Online

4.2k
Users

3.4k
Topics

22.3k
Posts