MV 13.3.0 / MacOS X 10.13 reagiert nicht mehr



  • Folgendes ist mir jetzt zweimal passiert:

    Ich starte MV 13.3.0 (auf MacOS X 10.13.6) und lade etwas herunter oder schaue auch nur, was es Neues gibt.

    Dann mache ich irgendwas anderes am Computer, und MV geht in den Hintergrund.

    Wenn ich dann MV wieder in den Vordergrund hole, reagiert es nur noch “beschränkt” auf meine Klicks und Eingaben.

    Was letztes Mal ging: einen Film runterladen (klick in Filmliste / Downloadsymbol)
    Was nicht geht: Im Suchfeld etwas eingeben (der Cursor wird dort nicht mal angezeigt wen mann reinklickt) oder den Suchbereich ändern (Buchsymbol), Filmliste neu laden, Filter anzeigen, überhaupt alles, was im oberen Balken zwischen “Filme / Downloads” und den angezeigten Titeln ist.

    Irgendwann, wenn man schon gar nicht mehr dran glaubt, geht plötzlich das Filterfenster auf, und man kann MV wieder “wie normal” verwenden.

    Woran mag das liegen?
    Am Computer - ein iMac (Retina 5K, 27-inch, Late 2015) 3.2 GHz Intel Core i5, 8 GB 1867 MHz DDR3?
    Am Betriebssystem - macOS High Sierra 10.13.6 (17G8030)
    An MediathekView - Version 13.3.0
    Am Typ, der da vor dem Bildschirm hockt und keine Geduld hat? 🤔


  • Entwickler

    @mac-christian Also dieses Verhalten ist mir unbekannt. Ich habe es auch häufiger minutenlang im hintergrund und arbeite nicht damit. Wenn ich wieder damit arbeite läuft es problemlos.

    Ich kann es mal detaillierter beobachten aber ich glaube da wird nicht viel bei rum kommen.

    Es gibt ein Phänomen dass MV nicht reagieren will auf dem mac wenn man es startet und es in den Hintergrund schickt so lange die Filmliste noch nicht dargestellt ist. Der Grund dafür ist unbekannt bisher.

    Woran mag es liegen? (Antworten dazu)

    1. Eher nicht, der ist besser ausgestattet von der Auflösung und Power als mein MBP 2012
    2. Schon eher, aus meiner Sicht spricht nichts gegen ein Upgrade auf Mojave
    3. Natürlich nicht! 😃
    4. Definitiv! 🙂


  • @DerReisende77 sagte in MV 13.3.0 / MacOS X 10.13 reagiert nicht mehr:

    Es gibt ein Phänomen dass MV nicht reagieren will auf dem mac wenn man es startet und es in den Hintergrund schickt so lange die Filmliste noch nicht dargestellt ist. Der Grund dafür ist unbekannt bisher.

    Das ist ein guter Hinweis! Danke! Hat mir geholfen.



  • Ich habe dasselbe Problem. 13.3.0 reagiert fast nie auf einen Klick in das Suchfeld “Thema/Titel”. Ich bin zu 13.2.1 zurückgegangen.


  • Entwickler

    @macfan Das hilft leider überhaupt nicht weiter. Welches macOS verwendest Du und wann/wie tritt der Fehler auf? Hast Du die Hinweise weiter oben beachtet, sprich: Programm starten und warten bis es komplett angezeigt wird?



  • Dieses Problem habe ich auch, allerdings auf Windows. Das Programm reagiert einfach nicht, sogar nach Stunden!



  • @aaaaa nein hast du nicht. Dein Problem tritt auf, weil das JRE statt JDK installiert ist. Das war hier im Forum oft genug ein Thema.



  • Ich habe mal bis zu einer neuen Version gewartet. Aber der Fehler tritt in 13.5.0 genauso auf.

    @DerReisende77 sagte in MV 13.3.0 / MacOS X 10.13 reagiert nicht mehr:

    Welches macOS verwendest Du

    10.14.6

    und wann/wie tritt der Fehler auf?

    Ich warte, bis die Filmliste da ist. Dann möchte ich einen Film suchen, klicke in das Suchfeld, aber es gibt dort keinen Einfügecursor und man kann nichts eingeben.

    Hast Du die Hinweise weiter oben beachtet, sprich: Programm starten und warten bis es komplett angezeigt wird?

    Ja.



  • Passierte und passiert bei mir immer wieder, z.B. jetzt gerade, mit diversen 13.3-Inkarnationen und macOS 10.14.x:

    01eff54c-b828-43f8-a7bc-6ebddd4bde84-image.png

    Erfahrungsgemäß werden angestoßene Downloads jedoch sauber ausgeführt, es scheint nur die »Oberfläche« zu sein, die nicht mehr ansprechbar ist.
    Daher warte ich dann einfach immer, bis der letzte Download abgeschlossen, also einige Minuten alt ist, dann schieße ich das Programm ab 😃 und starte es neu. Nervt, aber … geht.


    Ach ja, und bissl off-topic: Vorsicht in der Downloadliste … manchmal presse ich automatisch ctrl+G, um einen Eintrag zu entfernen, da passiert aber nichts (ich muss auf die Mülltonne klicken!) — dafür wird aber in der Filmliste ein Film als »gesehen« markiert und ausgeblendet! So hab’ schon einige Filme verpasst, bis es mir klar wurde.



  • Hier exakt dasselbe Problem. Ich habe noch die alte Version 13.2 (von Aug. 2018) parallel installiert, die funktioniert problemlos. Soll heißen, man kann sie starten und sofort in den Hintergrund schicken wo sie ggf. die Filmliste aktualisiert, und wenn man sie dann später aktiviert geht alles.
    Seit der 13.3 klappt das nicht mehr. Wenn man startet und die App gleich in den Hintergrund schickt geht anschließend gar nichts mehr im UI. Mit der 13.5 ist es schlimmer geworden, die Systemlast geht auf 100% und die Lüfter heulen los, wenn man die App nach vorne holt und in das Suchfeld klickt.
    Immerhin scheint sie zu laufen wenn man sie nach dem Starten im Vordergrund lässt bis sie die Filmliste aktiviert hat. Mal sehen wie es läuft wenn man sie danach im Hintergrund lässt und nur alle paar Tage aktiviert (das ist mein normales Szenario - mit 13.2. geht das problemlos).



  • @macfan sagte in MV 13.3.0 / MacOS X 10.13 reagiert nicht mehr:

    Ich habe mal bis zu einer neuen Version gewartet. Aber der Fehler tritt in 13.5.0 genauso auf.

    Es ist sehr selten, dass 13.5.0 mal richtig bedient werden kann. Hier liest man auch nichts mehr von den Entwicklern. Wird der Fehler nicht weiter verfolgt?

    Gruß, Horst



  • @macfan sagte in MV 13.3.0 / MacOS X 10.13 reagiert nicht mehr:

    Es ist sehr selten, dass 13.5.0 mal richtig bedient werden kann. Hier liest man auch nichts mehr von den Entwicklern. Wird der Fehler nicht weiter verfolgt?

    Wenn du MV während des Ladevorgangs in den Hintergrund schickst, kann das passieren - sonst passiert es (bei mir jedenfalls) nicht. Und wenn du genug Geduld hast, “erwacht” MV auch von seinem Mittagsschlaf.


  • Entwickler

    @macfan wenn Du die Threads dazu verfolgt hättest wäre dir aufgefallen das es einen workaround gibt der auch gerade nochmals gepostet wurde. Weiterhin habe ich vorher mal erklärt das es sich um einen Fehler in javafx handelt. Man muss also abwarten wann/ob jemand bei denen sich bereit erklärt das zu fixen. Aufgrund diverser Fehler von javafx auf den anderen Plattformen bewegen wir uns schon auf der neuesten möglichen Form.

    Von daher ist es am sichersten: starten, im Vordergrund halten bis die Liste komplett geladen und angezeigt wird und erst danach in den Hintergrund.

    Sollte ich vorher einen workaround im code finden kannst du dir sicher sein das ich den veröffentlichen werde.



  • @DerReisende77 Könnte man hier nicht ein Schloss dran hängen?


  • Entwickler

    @mac-christian ja kann man. Und nun dicht.


Log in to reply
 

87
Online

3.6k
Users

2.9k
Topics

18.2k
Posts