Neuer Rechner, Mediathekview startet gar nicht



  • System:
    Windows 10 pro 1903 (Build 18362.207) (aktuelle Version) 64 bit
    Java build 1.8.0_212-b10 64 bit
    Mediathekview 13.2.1

    Ich benutze Mediathekview schon seit Jahren auf mehreren Windows-Rechnern. Auf meinem alten Desktoprechner läuft dieselbe Software (Windows, Java, Mediathekview) vollkommen problemlos.

    Auf meinem neuen Notebook sieht es aber so aus:

    C:\Program Files (x86)\MediathekView-13.2.1>java -Xmx1g -XX:+UseConcMarkSweepGC -jar MediathekView.jar


    | / | | () | | | | | | | | | ()
    | . . | ___ | | __ | || |_ | | | | | | _____ __
    | |/| |/ _ / | |/ _ | _| ’ \ / _ \ |/ / | | | |/ _ \ \ /\ / /
    | | | | __/ (
    | | | (
    | | |
    | | | | __/ <\ _/ / | __/\ V V /
    _| |
    /_|_,||_,|_|| ||_||_\/||__| _/_/

    . Portable Mode: false
    . Proxy Authentication: not configured
    Exception in thread “AWT-EventQueue-0” java.lang.ExceptionInInitializerError
    at mediathek.MediathekGui.<init>(MediathekGui.java:1006)
    at mediathek.windows.MediathekGuiWindows.<init>(MediathekGuiWindows.java:9)
    at mediathek.Main.getPlatformWindow(Main.java:292)
    at mediathek.Main.lambda$startGuiMode$0(Main.java:282)
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    at java.awt.EventQueue.access$500(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.awt.EventQueue$3.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
    Caused by: java.lang.NullPointerException
    at com.sun.javafx.tk.quantum.QuantumToolkit.resumeTimer(QuantumToolkit.java:511)
    at com.sun.javafx.tk.quantum.QuantumToolkit.access$000(QuantumToolkit.java:135)
    at com.sun.javafx.tk.quantum.QuantumToolkit$PulseTask.set(QuantumToolkit.java:202)
    at com.sun.javafx.tk.quantum.QuantumToolkit.setAnimationRunnable(QuantumToolkit.java:865)
    at com.sun.javafx.tk.quantum.MasterTimer.postUpdateAnimationRunnable(MasterTimer.java:105)
    at com.sun.scenario.animation.AbstractMasterTimer$MainLoop.updateAnimationRunnable(AbstractMasterTimer.java:324)
    at com.sun.scenario.animation.AbstractMasterTimer$MainLoop.access$100(AbstractMasterTimer.java:253)
    at com.sun.scenario.animation.AbstractMasterTimer.addPulseReceiver(AbstractMasterTimer.java:176)
    at javafx.animation.Animation.addPulseReceiver(Animation.java:148)
    at javafx.animation.Animation.startReceiver(Animation.java:154)
    at javafx.animation.Animation.play(Animation.java:913)
    at javafx.animation.Animation.playFromStart(Animation.java:961)
    at mSearch.tool.ApplicationConfiguration$EvtListener.onEvent(ApplicationConfiguration.java:96)
    at mSearch.tool.ApplicationConfiguration$EvtListener.onEvent(ApplicationConfiguration.java:79)
    at org.apache.commons.configuration2.event.EventListenerList.callListener(EventListenerList.java:297)
    at org.apache.commons.configuration2.event.EventListenerList.access$200(EventListenerList.java:56)
    at org.apache.commons.configuration2.event.EventListenerList$EventListenerIterator.invokeNextListenerUnchecked(EventListenerList.java:421)
    at org.apache.commons.configuration2.event.EventListenerList$EventListenerIterator.invokeNext(EventListenerList.java:361)
    at org.apache.commons.configuration2.event.BaseEventSource.fireEvent(BaseEventSource.java:235)
    at org.apache.commons.configuration2.AbstractConfiguration.setProperty(AbstractConfiguration.java:793)
    at mSearch.tool.ApplicationConfiguration.createDefaultConfigSettings(ApplicationConfiguration.java:135)
    at mSearch.tool.ApplicationConfiguration.loadOrCreateConfiguration(ApplicationConfiguration.java:122)
    at mSearch.tool.ApplicationConfiguration.<init>(ApplicationConfiguration.java:68)
    at mSearch.tool.ApplicationConfiguration.<clinit>(ApplicationConfiguration.java:58)
    … 18 more

    Und dann hängt der Java-Prozess. In der mediathekview.log steht nur:

    [INFO ] 2019-06-30 09:42:06.467 [main] mediathek.Main - Portable Mode: false
    [INFO ] 2019-06-30 09:42:06.941 [main] mediathek.Main - Proxy Authentication: not configured

    Ich habe alle Startarten durchprobiert, keine führt zum Start, ist ja wohl ein Java-Problem.

    TV-Browser läuft vollkommen problemlos, es gibt also durchaus Java-Programme, die in dieser Umgebung laufen.

    Vielen Dank für eure Hilfe!

    Grüße
    Burkhard Schultheis


  • Globaler Moderator

    @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    ist ja wohl ein Java-Problem.

    Ich vermute eher javafx. Es gibt einige Beiträge dazu, dass ein neueres javafx bei Linux zumindest diese Sorte von Problemen bereitet. Schau mal bei Deinen Rechnern, ob sich diesbezüglich etwas unterscheidet.



  • @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    Auf meinem neuen Notebook sieht es aber so aus:
    C:\Program Files (x86)\MediathekView-13.2.1>java -Xmx1g -XX:+UseConcMarkSweepGC -jar MediathekView.jar

    Könnte das am “g” liegen? Probiere “-Xmx1G”.



  • @MenchenSued sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    ist ja wohl ein Java-Problem.

    Ich vermute eher javafx. Es gibt einige Beiträge dazu, dass ein neueres javafx bei Linux zumindest diese Sorte von Problemen bereitet. Schau mal bei Deinen Rechnern, ob sich diesbezüglich etwas unterscheidet.

    Ich habe alle Dateien, die “javafx” im Namen enthalten, auf beiden Rechnern mittels MD5-Summe verglichen. Bis darauf, dass die Datei C:\Program Files\Java\jre1.8.0_212\THIRDPARTYLICENSEREADME-JAVAFX.txt auf dem alten Rechner nicht vorhanden ist, gab’s keinen Unterschied.

    Danke!

    Grüße
    Burkhard



  • @DaDirnbocher sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    Auf meinem neuen Notebook sieht es aber so aus:
    C:\Program Files (x86)\MediathekView-13.2.1>java -Xmx1g -XX:+UseConcMarkSweepGC -jar MediathekView.jar

    Könnte das am “g” liegen? Probiere “-Xmx1G”.

    Ich sehe keinen Unterschied mit kleinem und großem G!

    Danke!

    Grüße
    Burkhard



  • @BuSchu sagte: C:\Program Files (x86)\MediathekView-13.2.1>java -Xmx1g -XX:+UseConcMarkSweepGC -jar MediathekView.jar

    Und wenn du “-XX:+UseConcMarkSweepGC” testweise mal weglässt? (Bringt wohl nichts, da ja die anderen Startdateien bei dir auch nicht funktionieren…)

    Ansonsten Java deinstallieren und Oracle Java installieren (hast es zwar wohl eh erst neu installiert…) Dasselbe mit MV, auch den ganzen Einstellungsordner löschen, damit alle möglichen Fehlerquellen eliminiert wären.

    Ist die gleiche Fehlermeldung wie hier.



  • @styroll
    Hallo styroll!
    Das Problem bei dem ubuntu-link ist vermutlich, dass MV java nicht finden kann. Wenn man mit MediathekView.sh startet und eine Zeile ähnlich wie meine (https://forum.mediathekview.de/topic/2504/nightlies-linux-änderungsvorschläge-für-mediathekview-sh) “JAVA_HOME=/usr/lib64/jvm/java-11-openjdk-11” einfügt, dann kann MV starten. In diesem Fall wohl “JAVA_HOME=/opt/java/jre1.8.0_212” . Da es sich um die gleiche Fehlermeldung handelt, könnte es bei Windows um das gleiche Problem handeln.



  • @styroll sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu sagte: C:\Program Files (x86)\MediathekView-13.2.1>java -Xmx1g -XX:+UseConcMarkSweepGC -jar MediathekView.jar

    Und wenn du “-XX:+UseConcMarkSweepGC” testweise mal weglässt? (Bringt wohl nichts, da ja die anderen Startdateien bei dir auch nicht funktionieren…)

    Ansonsten Java deinstallieren und Oracle Java installieren (hast es zwar wohl eh erst neu installiert…) Dasselbe mit MV, auch den ganzen Einstellungsordner löschen, damit alle möglichen Fehlerquellen eliminiert wären.

    Ist die gleiche Fehlermeldung wie hier.

    Meinst du ein neueres Java? 8 ist schließlich auch von Oracle! Läuft denn Mediathekview inzwischen mit openjdk 11? Mit der installierten Version 8 läuft es doch auf meinem alten Rechner. 😉

    Ich fürchte, der TV-Browser läuft mit 11 nicht!

    Ich probier’s mal aus und melde mich dann wieder!

    Grüße
    Burkhard


  • Globaler Moderator

    @BuSchu
    Obwohl es Meldungen gibt, die sagen, dass MV 13.2.1 mit Java 11 läuft, wird das vom Entwickler ausdrücklich nicht empfohlen. MV 13.3 wird aber mit Java 11 laufen und kommt in Kürze. MV 13.2.1 läuft mit einer aktuellen Java 8 Version.



  • @MenchenSued

    Stimmt! Aber wie du vielleicht nicht bemerkt hast, führt der Link zu den nightlies. Für die ist java11 schon richtig.



  • @MenchenSued sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu
    Obwohl es Meldungen gibt, die sagen, dass MV 13.2.1 mit Java 11 läuft, wird das vom Entwickler ausdrücklich nicht empfohlen. MV 13.3 wird aber mit Java 11 laufen und kommt in Kürze. MV 13.2.1 läuft mit einer aktuellen Java 8 Version.

    Das Rätsel ist gelöst! Auf meinem alten Rechner ist zusätzlich die 32-Bit-Version von Java 8 installiert. Und die habe ich nun auch auf meinem Notebook installiert und schon geht es!

    Jetzt habe ich aber das nächste Problem: Mediathekview gehört wohl zu den Programmen, die mit sehr hohen Bildschirmauflösungen nicht umgehen können. Mein Notebook hat ein 4k-Display und die Schrift ist nun in Mediathekview winzig. 😞 Hat hier jemand gleich einen Tipp oder soll ich ein neues Fass aufmachen? 😉

    Grüße
    Burkhard



  • @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    Jetzt habe ich aber das nächste Problem: Mediathekview gehört wohl zu den Programmen, die mit sehr hohen Bildschirmauflösungen nicht umgehen können. Mein Notebook hat ein 4k-Display und die Schrift ist nun in Mediathekview winzig. 😞 Hat hier jemand gleich einen Tipp oder soll ich ein neues Fass aufmachen? 😉

    Man kann zwar die Schrift vergrößern, aber das Menü bleibt winzig!

    Grüße
    Burkhard



  • @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    Hat hier jemand gleich einen Tipp oder soll ich ein neues Fass aufmachen?

    Du könntest auch die Forensuche verwenden, und z.B. diesen Thread finden.



  • @BuSchu
    Hallo Burghard
    Nein, in deinem Fall meine ich wirklich nur java8 und nicht “mit java11 versuchen” oder sowas. Aber je nachdem, wie du java installiert hast, weiß das Betriebssystem, wo java ist oder nicht. MV sucht an definierten Stellen danach, so wie in dem Link für linux beschrieben. Wenn java da nicht ist oder keine Verlinkung gefunden wird, geht es nicht weiter. Bei Windows könnte eine selbstgemachte Verlinkung helfen.
    Ansonsten habe unter linux mit den nightlies probiert und es ist sehr gut geworden, mit java11 aber eben.
    Grüße



  • @BuSchu
    Glückwunsch!
    Aber 64bit müsste doch auch laufen! Mir würde das keine Ruhe lassen, bis ich den Unterschied gefunden hätte.



  • @JFX4SUSE sagte: Aber 64bit müsste doch auch laufen!

    @JFX4SUSE sagte: Das Problem bei dem ubuntu-link ist vermutlich, dass MV java nicht finden kann. […] Da es sich um die gleiche Fehlermeldung handelt, könnte es bei Windows um das gleiche Problem handeln.

    Eben, dann einfach mit der richtigen Java-Version verknüpfen, bzw. den korrekten Pfad in einem Batch-File angeben und nicht jenen für 32-bit-Java, wenn man die 64-bit-Variante installiert hat:

    @BuSchu sagte: C:\Program Files (x86)\MediathekView-13.2.1>java

    “C:\Program Files” wäre korrekt für 64-bit-Programme (das weiss ich auch als macOS-User…)



  • @JFX4SUSE sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu
    Hallo Burghard
    Nein, in deinem Fall meine ich wirklich nur java8 und nicht “mit java11 versuchen” oder sowas. Aber je nachdem, wie du java installiert hast, weiß das Betriebssystem, wo java ist oder nicht. MV sucht an definierten Stellen danach, so wie in dem Link für linux beschrieben. Wenn java da nicht ist oder keine Verlinkung gefunden wird, geht es nicht weiter. Bei Windows könnte eine selbstgemachte Verlinkung helfen.
    Ansonsten habe unter linux mit den nightlies probiert und es ist sehr gut geworden, mit java11 aber eben.

    Ich hüte mich, bei der Installation einen anderen Pfad anzugeben! Aber offenbar braucht’s halt doch die 32-Bit-Version.

    Grüße
    Burkhard



  • @JFX4SUSE sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu
    Glückwunsch!
    Aber 64bit müsste doch auch laufen! Mir würde das keine Ruhe lassen, bis ich den Unterschied gefunden hätte.

    Mir ist das im Prinzip Wurscht, ob da nun eine 64- oder eine 32-Bit-Version installiert ist. Hauptsache es läuft, wenn auch mit teilweise winziger Schrift. Vielleicht ist die neue Version 13 da ja weiter. 😉

    Grüße
    Burkhard



  • @BuSchu sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @JFX4SUSE sagte in Neuer Rechner, Mediathekview startet gar nicht:

    @BuSchu
    Glückwunsch!
    Aber 64bit müsste doch auch laufen! Mir würde das keine Ruhe lassen, bis ich den Unterschied gefunden hätte.

    Mir ist das im Prinzip Wurscht, ob da nun eine 64- oder eine 32-Bit-Version installiert ist. Hauptsache es läuft, wenn auch mit teilweise winziger Schrift. Vielleicht ist die neue Version 13 da ja weiter. 😉

    Grüße
    Burkhard

    So, auch das 4k-Problem ist stark abgemildert. Ich habe eine Verknüpfung in der Taskleiste eingerichtet, dann das Kontextmenü aufgerufen und da unter “Kompatibiltät” -> Hohe DPI-Einstellungen “Verhalten bei hoher DPI-Skalierung überschreiben” angekreuzt, “Skalierung durchgeführt von Anwendung”.

    Grüße
    Burkhard



  • @BuSchu
    Gemeint war eine zusätzliche Verknüpfung anzulegen. Aber ein anderer Installationspfad ist auch immer wieder reizvoll. Gerade wenn man bei Windows Betriebssystem und Programme getrennt haben will.
    Schönes Rest-Wochende!


Log in to reply
 

62
Online

3.6k
Users

2.9k
Topics

18.1k
Posts