MV startet nicht



  • Hallo,

    Ich habe MediathekView-latest.tar.gz heruntergeladen und entpackt.
    Der Start über die Komandozeile führt zu folgender Fehlermeldung:

    mediathekview
    Fehler: Hauptklasse mediathek.Main kann nicht initialisiert werden
    Ursache: java.lang.NoClassDefFoundError: com/jidesoft/utils/ThreadCheckingRepaintManager

    Mein System:

    Ubuntu 18.10

    Was kann ich machen, um das Programm (wie bisher) zu starten?

    Krabat 52



  • @krabat52 Ich tippe mal auf veraltete Java Version. Aktuell ist Version 8 Update 191. Was ist bei dir installiert?



  • @Cloud9

    openjdk version “1.8.0_181”
    OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-1ubuntu0.18.10.1-b13)
    OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

    Hilft das weiter?

    LG

    K



  • @krabat52 Nicht wirklich. Ist zwar nicht die aktuellste Version, aber auch nicht wirklich alt.
    Ich hatte nach Installation von MV 13.2.1 auch Java Probleme (Filmliste wurde nicht geladen) und bei mir hat es geholfen, die OpenJDK durch das Original von Oracle zu ersetzen.
    Da die Fehlermeldung bei dir aber eine andere ist wäre es mir lieb wenn jemand kompetenteres sich hierzu äussern könnte.
    Hilfreich wäre dabei sicher, wenn du die Datei mediathekview.log aus dem Verzeichnis .mediathek3 hier hochladen könntest.


  • Entwickler

    Schau Mal bitte mit apt search ob es dort eine Bibliothek namens jide-oss oder jide-commons gibt. Die scheint bei dir nicht vorhanden zu sein.
    Der Fehler hat nichts mit einem zu Alten Java zu tun. Es fehlt eine Klasse die in jide vorhanden ist.



  • Das Paket heißt libjide-oss-java



  • in
    /usr/share/doc

    finde ich
    /usr/share/doc

    einen Ordner, der libjide-oss-java heißt.

    K



  • Habe den gleichen Fehler:
    “Fehler: Hauptklasse mediathek.Main kann nicht initialisiert werden
    Ursache: java.lang.NoClassDefFoundError: com/jidesoft/utils/ThreadCheckingRepaintManager”

    Benutze Ubuntu Mate 18.10, java-1.11.0-openjdk-amd64 und Mediathekview VERSION=13.0.6.
    Ich habe noch keine Lösung gefunden, gibt es eine?



  • @Winny sagte in MV startet nicht:

    java-1.11.0-openjdk-amd64

    “Hinweis: MediathekView ist NICHT mit Java 9 und höher kompatibel! Es wird zwingend Java 8 vorausgesetzt.”


  • Administrator

    @Winny sagte in MV startet nicht:

    VERSION=13.0.6.

    13.0.6 ist veraltet und wird von uns nicht mehr unterstützt.


Log in to reply
 

58
Online

2.9k
Users

2.3k
Topics

14.3k
Posts