Mediathek 13.0.6 startet nicht mehr



  • Hallo,
    vor ein paar Wochen habe ich Ubuntu 18.04 64bit mit Mediathekview 13.0.6. installiert. Alles lief prima. Java-Versionen sind installiert wie folgt:
    java -version
    openjdk version “10.0.2” 2018-07-17
    OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.1)
    OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.1, mixed mode)

    Seit gestern startet MV nicht mehr. Ich bekomme folgende Meldung im Terminal:
    mediathekview
    . Proxy Authentication: not configured
    Exception in thread “main” java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
    at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:488)
    at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
    at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
    at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1608)
    at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
    at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
    at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
    at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
    at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
    at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:532)
    at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:613)
    at java.desktop/java.awt.Toolkit.getEventQueue(Toolkit.java:1494)
    at java.desktop/java.awt.EventQueue.invokeLater(EventQueue.java:1312)
    at mediathek.Main.startGuiMode(Main.java:153)
    at mediathek.Main.startUI(Main.java:145)
    at mediathek.Main.start(Main.java:129)
    at mediathek.Main.main(Main.java:116)
    Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    at java.base/java.lang.Class.forName0(Native Method)
    at java.base/java.lang.Class.forName(Class.java:374)

    Hat jemand eine Ahnung, wo man da nachschauen/herumschrauben koennte?


  • Administrator

    Java 10 ist dein Problem. Es braucht Java 8.



  • @nicklas2751 Ja, ok. Ich meine, irgendwo im Forum gelesen zu haben, dass die Einschraenkung Java 8 nur fuer die neueren MV-Versionen ab 13.1 gilt. Und meine Version 13.0.6. lief ja etliche Wochen mit Java 10 problemlos.
    Wenn das denn so ist, installiere ich Java 8 und probier es nochmal aus.

    Laeuft die Beta 13.2 beta 2 mit Java 10? Dann wuerde ich mich da mal draufstuerzen.


  • Globaler Moderator



  • @iks-jott Mit Java 8 hab ich dasselbe Problem:
    java -version
    openjdk version “1.8.0_181”
    OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-0ubuntu0.18.04.1-b13)
    OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)
    mediathekview
    . Proxy Authentication: not configured
    Exception in thread “main” java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
    at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:488)
    at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
    at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
    at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1608)
    at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
    at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
    at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
    at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
    at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
    at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:532)
    at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:613)
    at java.desktop/java.awt.Toolkit.getEventQueue(Toolkit.java:1494)
    at java.desktop/java.awt.EventQueue.invokeLater(EventQueue.java:1312)
    at mediathek.Main.startGuiMode(Main.java:153)
    at mediathek.Main.startUI(Main.java:145)
    at mediathek.Main.start(Main.java:129)
    at mediathek.Main.main(Main.java:116)
    Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
    at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
    at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    at java.base/java.lang.Class.forName0(Native Method)
    at java.base/java.lang.Class.forName(Class.java:374)
    at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:485)

    In einem anderen Thread (finde ich auf die Schnelle nicht), hatte jemand ein aehnliches Problem und vermutet einen Zusammenhang mit der Filmliste (zu gross/lang). Das wuerde auch erklaeren, dass bis gestern meine Version lief.


  • Globaler Moderator

    @hein-bloed sagte in Mediathek 13.0.6 startet nicht mehr:

    Zusammenhang mit der Filmliste (zu gross/lang)

    Du kannst in den Einstellungen ja mal die Filmliste verkürzen, z.B. nur die Filme der letzten 8 Tage laden.

    0_1535117553049_Bildschirmfoto vom 2018-08-24 15-32-01.png

    GGf. direkt in der mediathek.xml patchen, falls die Oberfläche gar nicht mehr angezeigt wird:
    <system-anz-tage-filmilste>8</system-anz-tage-filmilste>



  • …dazu muesste das Programm ja erstmal laufen. Aber ich komme der Sache schon naeher. Nach aendern des defaults von Java 10 auf Java 8 konnte ich in /usr/share/mediathekview die MediathekView.jar starten. Weiss der gelbe Gockel, warum sich das in den letzten Wochen unter Java 10 von der Taskleiste aus starten liess…
    Jetzt laeuft MV zumindest wieder. Ich werd mich jetzt mal auf 13.2 beta 2 stuerzen.


  • Entwickler

    Versuch das Mal: Link


 

93
Online

2.5k
Benutzer

2.1k
Themen

12.4k
Beiträge