Nach Update von 13.0.1 auf 13.0.3 Java Probleme



  • OS: ubuntu 17.04
    Java: OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-2ubuntu1.17.04.3-b11)

    MV 13.0.1 funktioniert ohne Probleme.
    Habe dann die Datei /usr/share/mediathekview/MediathekView.jar ausgetauscht
    und dann MV gestartet und bekam foltende Java Fehlermeldungen:

    /usr/share/mediathekview$ ./MediathekView.sh
    Error: A JNI error has occurred, please check your installation and try again
    Exception in thread “main” java.lang.NoClassDefFoundError: com/jidesoft/utils/ThreadCheckingRepaintManager
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
    at java.lang.Class.privateGetMethodRecursive(Class.java:3048)
    at java.lang.Class.getMethod0(Class.java:3018)
    at java.lang.Class.getMethod(Class.java:1784)
    at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
    Caused by: java.lang.ClassNotFoundException: com.jidesoft.utils.ThreadCheckingRepaintManager
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    … 7 more

    Tausche ich die Datei MediathekView.jar wieder zurück zur Version 13.0.1 funktioniert alles wieder wie gehabt.
    Was muss ich tun damit v13.0.3 funktioniert?


  • Globaler Moderator

    @heinerhsch
    MediathekView.jar allein reicht nicht. Auch die libs müssen ausgetauscht werden. Am besten ALLES auspacken, dann geht sicherlich nichts schief.


  • Administrator

    @heinerhsch hast du es mit der Paketverwaltung oder per hand installiert?



  • Habe jetzt das lib-Verzeichnis ebenfalls nach /usr/share/mediathekview/ kopiert.
    Jetzt funktioniert auch die v13.0.3.
    Problem gelöst.

    Die v13.0.1 funktioniert allerdings ohne ein Verzeichnis /usr/share/mediathekview/lib/.
    Ggf. liegen die Dateien hier woanders?!
    Die Installation habe ich über die Paketverwaltung vorgenommen, glaube ich.


  • Administrator

    @heinerhsch leider hab ich es noch nicht geschafft es wieder in die paketquellen zu bringen. Die libs wurden eventuell wo anders installiert oder durch andere Pakete abgedeckt und deswegen ging es. Glaube irgendjemand hatte mal für die 13.0.1 ein DEB gebaut.



  • Ich hatte dasselbe Problem wie HeinerHSch und wollte hier grad posten. Die og. Anleitung (lib-Verzeichnis und MediathekView.jar nach /usr/share/mediathekview zu kopieren) funktioniert.
    Nun meldet sich Version 13.0.3.


Anmelden zum Antworten
 

67
Online

1.1k
Benutzer

933
Themen

5.1k
Beiträge

Es scheint als hättest du die Verbindung zu MediathekView-Forum verloren, bitte warte während wir versuchen sie wieder aufzubauen.