Neuinstallation: 13.2.1 letzte funktionierende Version



  • Hi zusammen,

    ich hab heute auf meinem Win10 PC Mediathekview zum ersten Mal installiert. Zunächst wollte ich natürlich direkt das neueste Release probieren. Das funktioniert aber nicht. U.a. funktioniert dort auch die Uninstall-Routine nicht. D.h. die Links im Startmenü bleiben und auch der Ordner mit den Dateien ist nach wie vor vorhanden. Aber das ist nur das kleinere Übel.
    Wenn ich die 13.5.1 starte, kommt folgende Meldung:
    ce5918a0-04fc-4a04-905b-6f62a90f64bf-image.png

    Ok, nach ein bisschen Recherche wollte ich die Konfig dann mit einer älteren Version anlegen. Aber auch das bringt nichts. Aktuell ist die 13.2.0 die letzte funktionierende Version bei mir.
    EDIT: Gerade noch probiert: 13.2.1 funktioniert auch.

    Mit dem vorherigen Starten der 13.2.0 kommt dann folgende Meldung:
    80cd1ff4-8baa-408a-83e9-f3e78b68b539-image.png

    Ein schwarzes Fenster ist kurz zu sehen, geht aber direkt wieder zu.

    Hat jemand eine Idee, woran das liegen könnte?

    Viele Grüße



  • @Arcbound sagte in Neuinstallation: 13.2.1 letzte funktionierende Version:

    Mit dem vorherigen Starten der 13.2.0 kommt dann folgende Meldung:

    Ist Dir aufgefallen, daß Deine Shell hier anzeigt

    Version: 13.5.1
    

    Wenn ich 13.2.1 starte, dann steht da

    Version: MediathekView 13.2.1
    

    Das heißt, Du startest meiner Ansicht nach nicht die Version, die Du zu starten glaubst.

    Welche Bitness hat denn Dein Windows 10? 32-Bit oder 64-Bit?
    Wie startest Du MV 13.2.1? Über Desktop-Symbol, über Kommandozeile, …?
    Für 13.2.1 Hast Du ein JRE 8 installiert?



  • @rubikon Schon mal auf die Idee gekommen, dass das nicht die Meldungen von 13.2.1 sein soll, sondern schon die von 13.5.1, nachdem temporär 13.2.1 genutzt wurde, um die Benutzerdaten anzulegen?

    Wobei, das mit dem verweigerten Start bei fehlenden Benutzerdaten war doch ein Problem mit einer älteren Version.



  • @mvsfsvm sagte in Neuinstallation: 13.2.1 letzte funktionierende Version:

    das nicht die Meldungen von 13.2.1 sein soll, sondern schon die von 13.5.1, nachdem temporär 13.2.1 genutzt wurde, um die Benutzerdaten anzulegen?

    Sorry, stimmt. Mein Fehler.

    Ein 32-Bit Rechner scheint es auch nicht zu sein. Das sieht anders aus.

    @Arcbound die Datei ~\.mediathek3\mediathekview.log könnte noch Aufschlüsse geben (Namen etc. kannst gerne rauslöschen). Oder Du startest MV mal aus cmd - dann verschwände das schwarze Fenster nicht.



  • @rubikon
    EDIT: Ja, Win10 64bit, alle Versionen gestartet aus Powershell. Ja, für die älteren Versionen hab ich dann Java 8 installiert. Verhalten war vorher aber genauso.

    Egal ob Powershell oder cmd, das Fenster verschwindet immer. Das bekomme ich hier kurz zu sehen:
    ff2a838c-1fed-47b9-931c-036adb6d3bdd-image.png

    Inkl. des Ladescreens vorher.

    Logdatei:

    INFO  2020-03-29 23:10:16,768  [main] mediathek.Main (Main.java:156) - Portable Mode: false
    DEBUG 2020-03-29 23:10:16,891  [main] mediathek.Main (Main.java:234) - === Java Information ===
    INFO  2020-03-29 23:10:16,892  [main] mediathek.Main (Main.java:235) - Programmstart: 29.03.2020 23:10:16
    INFO  2020-03-29 23:10:16,894  [main] mediathek.Main (Main.java:237) - Version: 13.5.1
    DEBUG 2020-03-29 23:10:16,894  [main] mediathek.Main (Main.java:240) - maxMemory: 1024 MB
    DEBUG 2020-03-29 23:10:16,895  [main] mediathek.Main (Main.java:242) - Java:
    DEBUG 2020-03-29 23:10:16,895  [main] mediathek.Main (Main.java:245) - Vendor: AdoptOpenJDK
    DEBUG 2020-03-29 23:10:16,895  [main] mediathek.Main (Main.java:245) - VMname: OpenJDK 64-Bit Server VM
    DEBUG 2020-03-29 23:10:16,896  [main] mediathek.Main (Main.java:245) - Version: 11.0.4
    DEBUG 2020-03-29 23:10:16,896  [main] mediathek.Main (Main.java:245) - Runtimeversion: 11.0.4+11
    DEBUG 2020-03-29 23:10:16,896  [main] mediathek.Main (Main.java:247) - ===
    INFO  2020-03-29 23:10:16,896  [main] mediathek.Main (Main.java:70) - === JavaVM Parameter ===
    INFO  2020-03-29 23:10:16,896  [main] mediathek.Main (Main.java:76) - ========================
    INFO  2020-03-29 23:10:16,903  [main] mediathek.Main (Main.java:393) - Verzeichnis Einstellungen: C:\Users\*******\.mediathek3
    DEBUG 2020-03-29 23:10:17,864  [main] config.MVConfig (MVConfig.java:37) - User-Agent: MediathekView
    INFO  2020-03-29 23:10:17,864  [main] config.Daten (Daten.java:314) - Konfig wurde gelesen!
    DEBUG 2020-03-29 23:10:19,451  [AWT-EventQueue-0] update.ProgramUpdateCheck (ProgramUpdateCheck.java:140) - ProgramUpdateCheck Started.
    


  • @Arcbound nicht mein Tag heute. Ich hatte vorhin “schwarzes Fenster” mit DOS-Box verwechselt, Sorry!

    Ich fürchte, ich bin da überfragt und werde passen müssen.
    Mir fällt nur noch ein, zu schauen ob es noch weitere Fehlerausgaben gibt. Die kann man in Datei umleiten

    java ... -jar MediathekView.jar -d > console.txt 2> error.txt 
    

    Ob’s was brächte, statt des mit MV 13.5.1 mitgelieferten AdoptOpenJDK 11.0.4 mal ein anderes OpenJDK (JDK mit JavaFX!) zu probieren, z.B. Liberica (full version mit LibericaFX) wage ich nicht zu vermuten oder gar zu empfehlen.

    edit: Falls es am JavaFX liegen sollte, lieber Gegenprobe mit Liberica OpenJDK 14 als mit o.g. Liberica 11.0.6. (wg. JavaFX Bugs in Java 11 (zB bei macOS und KDE) packen die Entwickler zu MV 13.5.1 JavaFX 14ea mit)



  • @rubikon Passiert 😉
    Danke für die Vorschläge.



  • @Arcbound sagte in Neuinstallation: 13.2.1 letzte funktionierende Version:

    Ein schwarzes Fenster ist kurz zu sehen, geht aber direkt wieder zu.

    Beim Zähneputzen hatte ich eine letzt Idee. Vor ein paar Monaten (September) gab es einen Zirkelaufruf (endlos-Rekursion), der mit Stapelspeicherüberlauf abbrach (a.k.a. stackoverflow). Passierte beim Aufbau der Konfig. Dieser sollte in 13.5.1 aber behoben sein.

    Ich komme jetzt darauf, weil:
    Solche Zirkelaufrufe “frieren” das Programm typischerweise kurz ein, bevor es dann zum Absturz kommt.
    Mit etwas Glück müßte irgendwo in einer Fehlerausgabe eines solchen Programms der Auftritt des Zirkelaufrufs erkennbar sein. Vielleicht wie oben gesagt in std::error (Ausgabestrom 2)… aber ohne jede Gewähr oder konkrete Anhaltspunkte, daß das hier der Fall ist. Für mich war das Ding eigentlich damals durch.

    Sollte das oder etwas Ähnlcihes aber ggfs. auch hier der Fall sein, hülfe ggfs. eine korrekte config als Workaround, MV 13.5.1 gestartet zu bekommen. Ist nur ein sehr vages Gefühl, ohne jede Gewähr… Aber ist bei Dir VLC schon installiert und stimmt der Pfad zu VLC in der Datei ~/.mediathek3/mediathek.xml? (kommt mehrfach vor)

    Viel “ggfs.” “möglicherweise” und “vielleicht”, Sorry. 😞



  • @rubikon Mit folgendem Aufruf:

    .\jre\bin\java -Xmx1G -jar .\MediathekView.jar > console.txt 2> error.txt
    

    console.txt:

    . Portable Mode: false
    . Programmstart: 30.03.2020 11:11:43
    . Version: 13.5.1
    . === JavaVM Parameter ===
    -Xmx1G
    . ========================
    . Verzeichnis Einstellungen: C:\Users\Roland\.mediathek3
    . Konfig wurde gelesen!
    
    

    error.txt ist leer 😕

    Der Pfad zu VLC stimmt eigentlich.



  • @Arcbound das ist aber nicht nett vom Computer, daß er nichts ins Protokoll schreibt. 😤

    Für mich ist hier 🏳 🏳 ✋🏼 🙄 🤚🏻

    @Nicklas2751, OCPJP 👍
    … mal Fatal Error Log hs_err_pidxxxx.log im Verzeichnis .\ bzw. %TMP% bzw. %TEMP% suchen lassen und anschauen?



  • @Arcbound in der Windows Computerverwaltung, in der ➡ System ➡ Ereignisanzeige mit den ➡ Windows-Protokollen für ➡ Anwendungen müßte je MV Absturz ein Fehlereintrag stehen. Ist das bei Dir so? Und wenn ja, was steht denn bei so einem von MV-Absturz erzeugten Fehlereintrag im Reiter “Allgemein”? So was wie das hier? Bitte falls vorhanden Screenshot oder Text.

    Ggfs. kann man mit einer solchen Info das Problem ein bißchen eingrenzen und weitere Anhaltspunkte sehen.

    Ohne Gewähr.



  • Der Fehler:
    7099c5db-8b2f-44f7-a9e9-8e9045147367-image.png

    Die Information von Windows:
    7eb53dd4-d4e0-44ea-b92c-90b8877315e4-image.png

    Sieht für mich so aus, als hätte Java hier ein Problem mit DirectX 9 🤨


Log in to reply
 

69
Online

4.4k
Users

3.7k
Topics

24.4k
Posts