Wieder ORF



  • Während auf früher installierten Windows-Versionen ORF-Download mit Austausch des User-Agents nach wie vor funktioniert, bricht dieser auf erst kürzlich installierten Versionen zumindest von Win 10 sowie dualem Win 7/Win10 unbehebbar wieder ab - ausser bei direkten mp4 Angeboten. Installationsfehler können ausgeschlossen werden, alles wurde mehrfach wiederholt aufgesetzt und geprüft, User-Austausch “wasserdicht”. Bitte neuerliche Kontrolle und wenn möglich Abhilfe. Das Abspielen funktioniert klaglos.



  • @pacon zum Melden von Fehlern bitte die Anleitung befolgen, bitte auch mit Angabe, ob 32 Bit oder 64 Bit Betriebssystem.

    Ein Schuss ins Blaue trotzdem: Was passiert, wenn Du ffmpeg.exe in CMD direkt ausführst? - Es gab mal eine Zeit, in welcher das Maven build-skript die in MV mitgelieferte ffmpeg.exe falsch verpackt und dabei zerstört hat…



  • @pacon Lade doch die beiden Logfiles hoch, dass wir uns ein Bild machen können.



  • Windows 10 64bit - Java v.8 Upd 231 - wegen evtl. Beschädigung des ffmpeg_files Version 4.2.1 darüber kopiert und neu gestartet , kein Erfolg. Wie Ausführung in cmd direkt gehen soll, ist mir nicht recht klar.
    Die entscheidende Passage in den .logs lautet:INFO 2019-12-30 20:58:08,630 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.StarterClass (StarterClass.java:112) - [Download starten, Programmset: Speichern, Ziel: D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4, URL: https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8, Startzeit: 20:58:08, Programmaufruf: bin\ffmpeg.exe -user_agent"Mozilla" -i https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8 -c copy -bsf:a aac_adtstoasc “D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4”, Programmaufruf[]: bin\ffmpeg.exe<>-user_agent"Mozilla"<>-i<>https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8<>-c<>copy<>-bsf:a<>aac_adtstoasc<>“D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4”]
    INFO 2019-12-30 20:58:08,631 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.RuntimeExec (RuntimeExec.java:83) - =====================
    INFO 2019-12-30 20:58:08,632 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.RuntimeExec (RuntimeExec.java:84) - Starte Array:
    INFO 2019-12-30 20:58:08,634 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.RuntimeExec (RuntimeExec.java:85) - -> bin\ffmpeg.exe<>-user_agent"Mozilla"<>-i<>https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8<>-c<>copy<>-bsf:a<>aac_adtstoasc<>“D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4”
    INFO 2019-12-30 20:58:08,635 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.RuntimeExec (RuntimeExec.java:86) - =====================
    INFO 2019-12-30 20:58:10,928 [PROGRAMM DL THREAD: 9 Plätze - 9 Schätze: So schön ist Österreich 2019] starter.StarterClass (StarterClass.java:168) - [Download ist fertig und war fehlerhaft, Programmset: Speichern, Ziel: D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4, Startzeit: 20:58:08, Endzeit: 20:58:10, Restarts: 0, Dauer: 2 s, Dauer: <1 Min., URL: https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8, Programmaufruf: bin\ffmpeg.exe -user_agent"Mozilla" -i https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8 -c copy -bsf:a aac_adtstoasc “D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4”, Programmaufruf[]: bin\ffmpeg.exe<>-user_agent"Mozilla"<>-i<>https://apasfiis.sf.apa.at/ipad/cms-worldwide/2019-12-30_1739_sd_02_9-Plaetze---9-S_____14036614__o__1502671531__s14616468_8__BCK2HD_17393010P_18254908P_Q8C.mp4/playlist.m3u8<>-c<>copy<>-bsf:a<>aac_adtstoasc<>“D:\Filme\9 Plätze - 9 Schätze-9 Plätze - 9 Schätze_ So schön ist Österreich 2019-1361886204.mp4”]
    DEBUG 2019-12-30 20:58:36,269 [AWT-EventQueue-0] update.ProgramUpdateCheck (ProgramUpdateCheck.java:149) - ProgramUpdateCheck closed.



  • @pacon sagte in Wieder ORF:

    Installationsfehler können ausgeschlossen werden, alles wurde mehrfach wiederholt aufgesetzt und geprüft, User-Austausch “wasserdicht”

    Wenn ich für jedesmal, wo was wasserdicht geprüft worden ist, einen Euro bekäme …

    @pacon sagte in Wieder ORF:

    Startzeit: 20:58:08, Programmaufruf: bin\ffmpeg.exe -user_agent"Mozilla"

    Da ist was falsch!

    q.e.d.



  • @pacon

    Wie Ausführung in cmd direkt gehen soll, ist mir nicht recht klar.

    Die Überprüfung per CMD, ob ffmpeg.exe beschädigt ist, ließe sich per manuellem drüber Kopieren der ffmpeg.exe umgehen.

    Welche MV Version Du verwendest, hast Du trotz meiner Bitte immer noch nicht gepostet. Aber da Du von Java 8 sprichst und ansonsten nur den entscheidenden Ausschnitt des Log-Files pastest, muss es MV 13.2.1 oder älter sein.

    Programmaufruf: bin\ffmpeg.exe -user_agent"Mozilla" -i …

    Das ist wirklich falsch, vgl. hier. Auf welche Weise hast Du nach dem User-Austausch Deine Programmsets eingestellt? Es fehlt im o.g. ein Leerzeichen zwischen user_agent und “Mozilla”:

    edit: ab hier hatte ich Käse geschrieben. Das Nachfolgende ist, wie unten erwähnt, falsch.
    Du kannst testweise mal Deine settings.xml und mediathek.xml im Ordner %USERPROFILE%\.mediathek3 umbenennen - und dann nach dem Test zurückumbenennen.

    Dann wird MV beim nächsten Start diese Dateien neu erzeugen und sich neu einrichten und etwaige Fehler in den verwendeten Programmsets wären “wasserdicht” auszuschließen, wenn Du bis dahin an den frisch erzeugten Programmsets nichts bearbeitest.



  • @rubikon sagte in Wieder ORF:

    Das ist wirklich falsch, vgl. hier. Auf welche Weise hast Du nach dem User-Austausch Deine Programmsets eingestellt? Es fehlt im o.g. ein Leerzeichen zwischen user_agent und “Mozilla”:

    Nachdem das Logfile nicht hochgeladen wurde, sondern “nur” ein Ausschnitt reinkopiert wurde, habe ich bewusst keine Vermutung geäußert, was falsch ist. Es soll schon vorgekommen sein, dass die Forensoftware Zeichen umwandet/verschluckt.

    Für die Beurteilung, was genau falsch ist, wäre es wirklich notwendig, beide (!) Logfiles unbearbeitet (!) hochzuladen (!).

    Oder: Nachdem @pacon ja funktionierende Installationen hat, könnte er bei sich die entsprechenden Passagen in den Logfiles zwischen funktionierenden und nichtfuktionierenden Installationen vergleichen.

    Dann wird MV beim nächsten Start diese Dateien neu erzeugen und sich neu einrichten und etwaige Fehler in den verwendeten Programmsets wären “wasserdicht” auszuschließen, wenn Du bis dahin an den frisch erzeugten Programmsets nichts bearbeitest.

    Ich versteh nicht ganz. Gerade die relevanten Einstellungen für den ORF sind manuell zu machen und werden absichtlich nicht in den Standardeinstellungen eingebaut. (siehe auch Release-Notes zu 13.5)



  • @rubikon sagte: Die Überprüfung per CMD, ob ffmpeg.exe beschädigt ist

    Das dürfte aktuell kaum mehr ein Grund sein: Leute mit älteren Versionen, dürften das Problem in der Zwischenzeit schon behoben haben, und Neu-User instaliieren die aktuelle Version (wo es das Problem nicht gibt).

    Eigentlich liegt es praktisch immer an der Schalter-Einstellungen (auch wenn es noch andere Ursachen für das Problem gibt).

    @rubikon sagte: Du kannst testweise mal Deine settings.xml und mediathek.xml im Ordner %USERPROFILE%.mediathek3 umbenennen - und dann nach dem Test zurückumbenennen.

    Da es um zusätzlich nötige Modifikationen der Sets geht, ist das relativ sinnfrei…



  • @DaDirnbocher @styroll mea culpa. Zu der Sache mit den Standardeinstellungen und ORF hätte ich besser geschwiegen! 🙄



  • Danke für die Antworten. Mittlerweile habe ich den Fehler selbst gefunden und behoben. Er entsteht folgendermaßen:
    Wird von einer früheren Windows-Version auf Win 10 upgegradet, dann belässt diese Installation normalerweise alle Programmdaten unverändert. Wird nun trotzdem Mediathekview neu installiert, so werden offenbar die Daten nur überschrieben, aber wohl nicht richtig. Dabei entstehen - wahrscheinlich vor allem in den Verzeichnissen .mediathek3 und .openjfx, aber auch sonst ? - Fehler, die später Aufzeichnungen verhindern. Ich habe nun (2x) eine vorhandene funktionierende Installation einfach 1:1 über die fehlerhafte (aber ordnungsgemäß in die Registry eingetragene) kopiert - und nun funktioniert’s. Die Sache nun gründlich zu untersuchen, fehlt mir die Zeit.
    Da aber - entgegen meiner ersten Vermutung - offenbar keine neue Sperre durch den ORF vorliegt, ist die weitere Befassung durch das Forum hinfällig und der Thread zu schließen. Meine Anregung wäre nur, vielleicht die Installationsroutine daraufhin durchzusehen bzw. zu ergänzen, dass vor der Installation von Mediathekview alle dafür benötigten Speicherstellen immer auf das Vorliegen von Programmleichen geprüft und allfällige Dateien (auch Registryeintragungen?) verlässlich gelöscht werden, um eine wirklich saubere (Neu-)Installation zu gewährleisten. Manche Programminstallationsroutinen machen das erfreulicherweise bereits. Bei mir hat das sogar ein professionelles Uninstallationsprogramm übersehen, was zu meinen Problemen geführt hat!
    Vielen Dank noch für die liebe Hilfsbereitschaft!
    pacon



  • @pacon sagte: Meine Anregung wäre nur, vielleicht die Installationsroutine daraufhin durchzusehen bzw. zu ergänzen, dass vor der Installation von Mediathekview alle dafür benötigten Speicherstellen immer auf das Vorliegen von Programmleichen geprüft und allfällige Dateien (auch Registryeintragungen?) verlässlich gelöscht werden,

    Bis vor kurzem gab es gar keinen Installer (MV 13.2.1 und älter), und der jetzige Installer macht auch nichts anderes, als man vorher manuell gemacht hat: Er dekomprimiert und entpackt die Dateien und schreibt dann das MV-Programmverzeichnis an den angegebenen Pfad. Es wäre mir neu, dass MV Registry-Eintragungen vornimmt.

    Die Einstellungdateien werden erst beim Starten der Programme angelegt, und wenn da bei der Installation einer neueren Version bestehende Einstellungsdateien gelöscht würden, dann verliert man seine Einstellungen (eben z.B. damit die ORF-Aufnahme funktioniert). Dasselbe gilt auch, wenn man die Einstellungsdateien von einem anderen Rechner kopiert und auf einem neuen Rechner das Programm erstmalig installiert.

    Wird nun trotzdem Mediathekview neu installiert, so werden offenbar die Daten nur überschrieben, aber wohl nicht richtig.

    Wenn dem so wäre, hättest du gar keine angepassten Settings für die ORF-Aufnahme. Die MV-Einstellungen funktionieren default nicht beim ORF, die muss man einmalig manuell vornehmen.

    Installationsfehler können ausgeschlossen werden, alles wurde mehrfach wiederholt aufgesetzt und geprüft, User-Austausch “wasserdicht”

    Leider hast du nie beschrieben, wie du konkret vorgegangen bist. Deine oben formulierte Theorie bedeutet konkret, dass bei der Installation ein Leerschlag in den MV-Einstellungen verschluckt wurde, was sehr unplausibel ist.



  • @pacon sagte in Wieder ORF:

    über die fehlerhafte (aber ordnungsgemäß in die Registry eingetragene)

    … in die Registry eingetragen? Ich verstehe nur mehr Bahnhof.

    Meine Anregung wäre nur,

    Diese Anregung ist relativ sinnfrei, wenn …

    Die Sache nun gründlich zu untersuchen, fehlt mir die Zeit.

    … die Ursachen gar nicht genau bekannt sind.

    Mir scheint nach Deinem Post mehr unklar denn je. Auf der einen Seite redest von JAVA 8 (was wohl eine MV Version 13.2.1 oder früher bedeutet), gleichzeitig möchtest Anpassungen am Installationsprogramm (das erst nach Version 13.2.1 gibt), und andererseits ist nicht klar ob das Problem an der Neuinstallation von MV oder am Update der Windowsversion liegen soll …



  • @styroll sagte in Wieder ORF:

    Deine oben formulierte Theorie bedeutet konkret, dass bei der Installation ein Leerschlag in den MV-Einstellungen verschluckt wurde, was sehr unplausibel ist.

    Ich hatte in einem anderen Kontext beim Wechsel von Win 7 auf Win 10 (also genaugenommen auf Win 8, die haben aber manche ausgelassen) schon einmal einen Effekt mit einem Leerzeichen (space vs. no-break-space), wodurch manche Programme Probleme bekamen.

    Nachdem @pacon ja ein Windowsupdate andeutet, …

    Wird von einer früheren Windows-Version auf Win 10 upgegradet,

    … würd ich das nicht zur Gänze ausschließen, aber grundsätzlich bin ich da ganz bei dir …

    @styroll sagte in Wieder ORF:

    Leider hast du nie beschrieben, wie du konkret vorgegangen bist.

    … mit solchen “Fehlermeldungen” ist es schwierig, da fundiert zu helfen.



  • @DaDirnbocher sagte: Ich hatte in einem anderen Kontext beim Wechsel von Win 7 auf Win 10 […] schon einmal einen Effekt mit einem Leerzeichen (space vs. no-break-space)

    “Non breaking spaces” in einem Einstellungsfile (das nicht mal von Windows angelegt wurde und deshalb auch nicht manipuliert werden sollte)?

    Willst du also sagen, dass Windows bei dir bei einem Upgrade nicht windowseigene Dateien manipuliert hat (obwohl nur Kopieren, Verschieben oder – im Extremfall – Löschen von solchen Dateien Sinn ergäbe)?

    Ich hab unter Windows schon merkwürdige Dinge beim “Drüberkopieren” von Ordnern erlebt, so dass ich diese Funktion nie (mehr) verwende. Aber auch damit könnte ich das Problem des OP nicht erklären…

    EDIT:
    Und nach deiner Antwort unten habe ich keine Ahnung, was du mit deinem Post überhaupt sagen willst…



  • @styroll sagte in Wieder ORF:

    Willst du also sagen, dass Windows bei dir bei einem Upgrade nicht windowseigene Dateien manipuliert hat

    Nein.


Log in to reply
 

81
Online

3.8k
Users

3.1k
Topics

19.6k
Posts