ORF, kein abspielen mehr mit/unter windows 7



  • hallo,
    Problem wie Betreff, ein abspielen von orf-Beiträgen (auch srf) ist plötzlich unter windows 7 (x64) als BS nicht mehr möglich, sowohl älteres mv13.2.1 als auch aktuelle nightly (vom 27-11 sowie 4-12).
    Alle für orf notwendigen Einstellungen überprüft korrekt gesetzt (user agent sowie set bearbeiten/DL-ffmpeg + abspielen), daran kanns nicht liegen.
    Es scheint etwas in der betreffenden win7-Installation zu sein, dass da ein korrektes abspielen blockt. Vlc geht jeweils kurz auf, um dann sofort wieder zu verschwinden, die Übergabe ist anscheinend iwie gestört - ein DL ist zwar möglich springt aber erst spät an + dauert im Vergleich rel. lang.
    Ein Test in einer win7-vm mit der älteren mv13.2.1 ergab problemfreie Funktion auch mit orf/srf. An win7 allein kann es also nicht liegen.
    Wo kann man suchen, um die Bremse zu finden? Keine ähnlichen Probleme mit win 8.1 und 10.



  • @nayrun ich hatte mal das Problem, dass ich VLC als 32 Bit Programm unter C:\Programme (x86) installiert hatte - und MV zeigte ursprünglich dort hin.

    Später habe ich bei VLC auf 64 Bit gewechselt und das wurde entsprechend nach C:\Programme installiert. - und der in MV in den Sets hinterlegte Pfad zu VLC war durch die Umstellung zunächst falsch.

    Da hat dann der VLC in MV hat nicht mal gezuckt…

    Interessant wär mal, ob VLC tut, wenn Du den URL zur Playlist/Video zu Fuß, ohne Knopf im MV einfügst und abspielst.

    -bin unterwegs… Oder mal nach Log file von VLC suchen und lesen, ob der VLC dort was ausspuckt… ?



  • @nayrun sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Wo kann man suchen, um die Bremse zu finden?

    z.B, im Logfile vom MV.



  • @rubikon sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Interessant wär mal, ob VLC tut, wenn Du den URL zur Playlist/Video zu Fuß, ohne Knopf im MV einfügst und abspielst.

    kam erst jetzt zum nachschauen/probiern.
    In der betreffenden win7-Installation funktioniert genau das nicht, also kopieren einer url eines ORF-Beitrags aus MV und einfügen/abspielen in vlc via ‘Medien/Netzwerkstream öffnen’. kurze Suche, dann verabschiedet sich vlc. Bei srf startets kurz für ca. 1-2 sek., um dann ebenfalls sofort zu verschwinden. Alle anderen Sender ok. Also da klappt die Übergabe - sowohl aus MV, als auch per url-lnk in vlc direkt. DL genauso (orf-srf nada, alle anderen ok).
    Eine testweise genommene andere Win7-Installation (x32) zeigt keine Probleme mit ORF-SRF-Beiträgen, bis auf: DL orf-srf rel. langsam. Liegt dann also anscheinend an dieser speziellen win7-64 Install.
    Im logfile von MV werd ich mal nachschauen.



  • @nayrun sagte: Alle anderen Sender ok. Also da klappt die Übergabe - sowohl aus MV, als auch per url-lnk in vlc direkt. DL genauso (orf-srf nada, alle anderen ok).

    Beim ORF und SRF (und WDR) liegen HL-Streams vor, bei allen anderen Sender ist das Video als ganzes direkt referenziert.

    Leider schweigst du dich weiter über die verwendete VLC-Version aus…

    @nayrun sagte: In der betreffenden win7-Installation funktioniert genau das nicht, also kopieren einer url eines ORF-Beitrags aus MV und einfügen/abspielen in vlc via ‘Medien/Netzwerkstream öffnen’.

    Das wäre ein Hinweis, dass das Problem nicht bei den MV-Einstellungen bzw. bei MV liegt…

    @nayrun sagte: ein abspielen von orf-Beiträgen (auch srf) ist plötzlich unter windows 7 (x64) als BS nicht mehr möglich

    Das wäre ein Hinweis, dass Defender oder was auch immer für ein Sicherheitsprogramm nach einem Update möglicherweise gewisse Verbindungen blockiert.



  • @styroll
    vlc ist die aktuelle Version 3.0.8 (vetinari), sonst wäre es ausdrücklich erwähnt gewesen. Probiert in MV die x64 und die x32-Version, Ergebnisse je gleich (s.o.).
    Ein Block via defender scheidet aus, da windows7, der alte win7-defender ist deaktiviert. Das AV MS sec-essentials würde, wenn es denn blockierend wirkte, dies nur unter x64 tun, da eine zum Vergleich herangezogene win7-x32-Install ja tut mit orf/srf. Und der defender unter win8.1/10 ebenfalls keine Störung verursacht. Gibt kein weiteres Sicherheitsprogramm.
    Bliebe ein Win-update der letzten Zeit, dass da die Probleme (mit) verursacht hat/haben könnte?! kA.
    Hab das logfile mal durchgesehen, nichts direkt gefunden, dazu recht groß.
    Daher hier mal als Ausschnitt die letzten Zeilen mit error-Meldungen betreffend orf angehängt:
    ausschnitt_mediathekview_.log
    dass es wahrscheinlich eher nicht an MV, aber dafür wohl mehr an dieser einen windows-7 x64-Install liegt, war ja bereits erwähnt.



  • @nayrun sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Alle für orf notwendigen Einstellungen überprüft korrekt gesetzt (user agent sowie set bearbeiten/DL-ffmpeg + abspielen), daran kanns nicht liegen.

    Hmmm, ich tät einmal auf “falsche” Anführungszeichen tippen:

    f27641e1-c644-440b-b59e-68ef96dbe695-image.png

    Sollte das nicht so aussehen?

    49647b3c-4753-4c06-85a8-1b2990df8032-image.png



  • @DaDirnbocher sagte: ich tät einmal auf “falsche” Anführungszeichen tippen:

    Ich sehe im oben angehängten Logfiles gar keine Anführungszeichen an dieser Stelle (?).
    @nayrun: Man sollte beide Logfiles hochladen, wenn man dazu gebeten wird – das erspart viel unnötige Schreiberei…

    Und warum das Abspielen von ORF- und SRF-Streams mit VLC auch ausserhalb von MV nicht funktioniert, wäre damit (immer noch) nicht geklärt…



  • @styroll sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Ich sehe im oben angehängten Logfiles gar keine Anführungszeichen an dieser Stelle (?).

    Hmmm, ich habe einen Screenshot (bzw. einen Ausschnitt) gepostet. Keine Ahnung, warum Du das nicht siehst.



  • Die Passage mit dem user-agent und dem X mit den falschen Anführungszeichen kommt - wenn ich mich nicht verzählt habe - 8x vor.

    161c2de9-43ea-4448-a1e5-0f91185a7f56-image.png



  • @nayrun
    @DaDirnbocher sagte in ORF, kein abspielen mehr mit/unter windows 7:

    @styroll sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Ich sehe im oben angehängten Logfiles gar keine Anführungszeichen an dieser Stelle (?).

    Ich weiß nicht, ob sich die Namen dieser mE englischen Zeichen, imo “double typographic quotes”, 1:1 als “Anführungszeichen” ins Deutsche übertragen. Denn öffnende Deutsche Anführungszeichen stehen “unten” und nicht so wie die gesehenen “oben”. Jedenfalls könnte hier ein Copy&Paste Problem aus einer Quelle vorliegen, wo die Auto-Korrektur irgendeines Editor sich ungewollt ausgetobt hat…
    …und mE gehören diese mE “typographic double quotes” ersetzt durch “neutral double quotes” - oder einfach gesagt durch das gute alte ASCII Zeichen 0x22 (Hex) bzw. 34 (Dezimal)

    Bzgl. Abspielen mit VLC außerhalb MV -
    könnte man ggfs.mal die VLC Einstellungen (NACH Anfertigung einer Sicherungskopie) resetten? Ich glaube, die VLC Einstellungen liegen unter %USERPROFILE%/AppData/Roaming/VLC … ?



  • @rubikon sagte: Jedenfalls könnte hier ein Copy&Paste Problem aus einer Quelle vorliegen

    Da hast du wohl recht (das ist keine saubere Log-Datei vom Format her), denn das Problem hatte ich bislang noch nie mit Log-Dateien. Ein Doppelklick öffnet mir Log-Dateien in der Konsole (Console.app), wo ich keine Anführungszeichen sehe:

    MV-Log-Console.png

    Erst ein Öffnen mit einem Editor (BBEdit.app) zeigt mir auch, dass nicht die korrekten Anführungszeichen gesetzt sind (oder dass die Textcodierung verloren ging):

    MV-Log_BBedit.png



  • @styroll sagte in ORF, kein abspielen mehr mit/unter windows 7:

    das ist keine saubere Log-Datei vom Format her

    Jep. Wobei ich Dir nicht sagen kann, ob die typographic double quotes 0x93 und 0x94 so in den MV Einstellungen des OP stehen und entsprechend genau so in den Programmaufruf von VLC gingen, oder ob im MV korrekte 0x22 (neutral double quotes) stehen und die Verfälschung erst beim Ausschneiden / Bearbeiten des log-File zum Hochladen ins Forum entstanden sind. 🤔 🧐 😒

    @styroll sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Ein Doppelklick öffnet mir Log-Dateien in der Konsole (Console.app), wo ich keine Anführungszeichen sehe:

    Unbenannt.PNG

    Ich nehm normalerweise notepad++. Hier hab ich die Datei aber mal in einem Hex-Editor geöffnet und die Stelle mit der Maus markiert. Man sieht in der ASCII Tabelle dass hier mit 0x93 und 0x94 Zeichen oberhalb von 0x7F (127) zum Einsatz kommen also welche der übrigen 128 Positionen im Byte - außerhalb ASCII - und damit außerhalb des größten gemeinsamen Nenners aller Texteditoren. Das dürfte erklären, warum die 3 Editoren 3 verschiedene Darstellungen derselben Ausgangsdatei haben…🤢 🤮



  • also, danke der anregung(en),

    • ein zurücksetzen von vlc wurd nat. mehrfach versucht, daran liegts nicht. Auch ein übernehmen (kopieren) der Daten aus ‘\Users…\AppData\Roaming\vlc’ aus einer win8.1-Installation, wo MV ja problemlos mit orf/srf funkt (incl. Direkteingabe orf-url in den vlc), ergab Null Änderung.
    • Syntaxprobleme oder -Unterschiede beim Erstellungen der Einstellungen scheiden ebenfalls aus, u.a. wird immer aus der gleichen Datei kopiert/eingefügt - ein Fehler müsste also auch auf anderen Plattformen auftreten. Zudem wurde u.a. auch eine portable-MV-Version (= orf/srf funktional incl. Datenordner) aus der bereits erwähnten win8.1-Install in die betroffene win7-Install komplett übernommen. Also auch mit den funktionierenden Einstellungparametern. Keine Änderung.
      Insgesamt deuten alle Indizien auf einen Fehler in der betreffenden Windows-7(x64)-Installation hin, zumal ja eine als Vergleich herangezogene MV auf einer anderen win7-32 rel. problemfrei mit orf/srg tut. Zwar mit sehr zäh-langsam anspringendem DL, aber iwann gehts und abspielen ohne Probleme. Dieser auffallend zäh-langsame DL könnte ein win7-Prob sein.
      Den wirklichen Fehler zu finden ist zu anstrengend, zumal orf nur ab + an benötigt wird. Was dann mit w8.1/10 erledigt werden kann. 🙂
      bei Bedarf aber gern noch die log-Dateien komplett (hochlad ich kann).


  • @nayrun sagte in ORF, kein abspielen mehr mit/unter windows 7:

    also, danke der anregung(en),

    • ein zurücksetzen von vlc wurd nat. mehrfach versucht, daran liegts nicht.

      Den wirklichen Fehler zu finden ist zu anstrengend

    Ah ja. Anstrengend ist eigentlich nur für die Helfer, dass du es noch immer nicht fertiggebracht hast, die jeweils verwendeten VLC-Versionen sowie das evtl. Berichtigen der Anführungszeichen (auf einer deutschen Tastatur nach “SHIFT-2”) bekanntzugeben.



  • @nayrun sagte in ORF, kein abspielen mehr mit/unter windows 7:

    also, danke der anregung(en),

    Wow.

    Dein hochgeladener Logfileausschnitt belegt ganz klar, dass bei Deinem System was nicht stimmt.

    Entweder hast Du falsche Set-Einstellungen oder der Logfileausschnitt ist kein “echter” Logfileausschnitt.

    Darauf gehst Du mit keinem Wort ein. Sorry, das reduziert meine Lust zu helfen auf 0.

    bei Bedarf aber gern noch die log-Dateien komplett (hochlad ich kann).

    Danke, für mich besteht kein Bedarf. Such Dir für Deine Probleme, …

    @nayrun sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Den wirklichen Fehler zu finden ist zu anstrengend, zumal orf nur ab + an benötigt wird. Was dann mit w8.1/10 erledigt werden kann.

    … die Du dann eh nicht lösen willst, andere. Mir ist mein Zeit für sowas zu schade.



  • @pitbick sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Ah ja. Anstrengend ist eigentlich nur für die Helfer, dass du es noch immer nicht fertiggebracht hast, die jeweils verwendeten VLC-Versionen sowie das evtl. Berichtigen der Anführungszeichen (auf einer deutschen Tastatur nach “SHIFT-2”) bekanntzugeben.

    Oben steht aber - nachlesbar, schaffst du das? - “vlc ist die aktuelle Version 3.0.8 (vetinari)”
    erscheint leicht verstrahlt?! Da wird geantwortet, das wird ignoriert, überlesen. Und das dann bemeckert. Reife Leistung.
    Gilt auch für ‘DaDirnbocher’:
    Dass mit diesem Windows7-System was nicht zu stimmen scheint, wird vom TE nayrun doch eigentlich mehrfach angesprochen. Auch pot. falsche Einstellungen sind anfangs klar ausgeschlossen (“Alle für orf notwendigen Einstellungen überprüft korrekt gesetzt”), also angesprochen. so what?!
    Muss man grundlos so vernölt reagieren? Wenn man noch nicht mal richtig gelesen hat?
    vlt etwas entspannter. 😉



  • @phalinka sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Oben steht aber - nachlesbar, schaffst du das? - “vlc ist die aktuelle Version 3.0.8 (vetinari)”
    erscheint leicht verstrahlt?!

    VLC gibt es in verschiedenen Versionen: 32-Bit und 64-Bit. Ob aus beiden Systemen gleich installiert, steht nirgendwo. Diese unterscheiden sich auch in den entsprechenden Registry-Einträgen unter Windows. Schaffst DU das?

    Auch pot. falsche Einstellungen sind anfangs klar ausgeschlossen (“Alle für orf notwendigen Einstellungen überprüft korrekt gesetzt”), also angesprochen. so what?!

    Klar ausgeschlossen , latürnich! Anstatt die Einstellung hier vollständig anzugeben, einfach nur überprüft. Du bist der King.

    Such mal hier im Forum. Da steht auch was zu VLC 3.0.8.l

    Denken hilft!
    EOT



  • @phalinka sagte in ORF, kein abspielen mehr mit/unter windows 7:

    Auch pot. falsche Einstellungen sind anfangs klar ausgeschlossen (“Alle für orf notwendigen Einstellungen überprüft korrekt gesetzt”), also angesprochen. so what?!

    Das Logfile sagt aber was anderes.

    Es gibt genügend Threads von Leuten, die ganz sicher alle Einstellungen richtig eintragen haben und am Schluss hat sich dann herausgestellt, dass der Fehler doch falsche Einstellungen waren.

    Aber egal, es ist nicht mein Problem. Und derjenige der ein Problem hat, hat klar gesagt, dass er es gar nicht lösen will. Also EOT von meiner Seite.



  • Habe auch unter Win 10 (merkwürdigerweise nur auf 2 von 3 PCs ( den neuer installierten)) beim Speichern Abbruch mit Fehler. Alles geprüft, -user_agent o.K. alle drei PCs haben 100% gleiche Software. Andere ffmpeg Version geprüft, kein Erfolg.
    Warum auf dem einen PC der Download funktioniert, auf den anderen nicht, keine Ahnung. Error.log zeigt folgende Eintragung:
    Exception in thread “FilmeImportierenAutoThread” java.util.ConcurrentModificationException
    at java.base/java.util.ArrayList.sort(ArrayList.java:1751)
    at java.base/java.util.Collections.sort(Collections.java:145)
    at mediathek.filmlisten.FilmeLaden.undEnde(FilmeLaden.java:269)
    at mediathek.filmlisten.FilmeLaden$1.fertig(FilmeLaden.java:77)
    at mediathek.filmlisten.ImportFilmliste.fertigMelden(ImportFilmliste.java:99)
    at mediathek.filmlisten.FilmeImportierenAutoThread.run(FilmeImportierenAutoThread.java:49)
    Was kann ich noch erforschen ?


Log in to reply
 

85
Online

4.3k
Users

3.7k
Topics

24.2k
Posts