Check der Java-Version ist fehlerhaft



  • Mediathekview_Portable.exe
    Version: 13.3.0
    Windows 7 Ultimate

    Hier sind offensichtlich ein Paar Bugs enthalten !

    (1)
    Das Programm verlangt Java Version 11.
    Es wird gestartet mit OpenJdk 12.0.1

    Die Prüfung müsste also die minimal benötigte Java-Version
    prüfen und keine Gleichheit der Hauptversion !

    Der Start des jar-Files funktioniert.
    D.h. jar-File und exe haben eine unterschiedliche Funktionalität/Version ??

    (2)
    Wenn man das Jar startet, dann wird offensichtlich davon ausgegangen, dass
    eine vorhandene Datenbank zu löschen ist.
    Allerdings scheint das Programm diese Datenbank vorher schon zu lesen bzw. auf sie
    zuzugreifen !
    (Sysinternals Process Explorer zeigt, dass nur java.exe auf diese Datei zugreift !)

    –> java.nio.file.FileSystemException … databasemediathekview.mv.db

    (3)
    Obwohl die letzte Version am 11.08.19 heruntergeladen wurde, beschwert sich
    das Programm, dass ffmpeg nicht in der richtigen Version vorliegen würde und
    man die letzte Version herunteladen sollte.

    Das habe ich doch irgendwie eine Viertelstunde vorher gerade gemacht !!

    MfG

    Gerhard Fries


Log in to reply
 

81
Online

3.6k
Users

2.9k
Topics

18.3k
Posts