Browser-Auswahl



  • Ich weiss nicht, ob es mit MediathekView zu tun hat, oder ob das Problem woanders liegt. Auf jeden Fall ist es nervig:

    In den Einstellungen meines Mac (OS X 10.13.6) habe ich Firefox als Browser eingestellt. Das funktioniert auch, und Links zu Webseiten werden in Firefox geöffnet. Nur innerhalb von MV (13.2.1) - und dort bisher auch nur beim Sender SRF - werden die Seiten in Safari geöffnet, wenn ich bei einer Beschreibung weiterlesen möchte und auf “Link zur Website” klicke. Und auch da sind es nicht alle Sendungen, bei denen Safari kommt statt Firefox…

    Hat da irgendwer eine Idee, was ich tun könnte?



  • @mac-christian
    Hi,schau mal in MV unter Einstellungen/erweitert/Webbrowser.
    LG



  • @sheldon Da war tatsächlich Safari eingestellt. Umgestellt, Alles beendet, heute früh wieder gestartet und - immer noch geht Safari auf, wenn ich auf einen Link klicke… Ärgerlich!

    Bildschirmfoto 2019-02-28 um 11.12.02.jpg

    Bildschirmfoto 2019-02-28 um 11.15.58.jpg

    Bildschirmfoto 2019-02-28 um 11.16.15.jpg

    Weitere Ideen?



  • Ich hab zwar keinen Mac, aber mit MV12 unter Windows hatte ich ähnliche Probleme. Da öffnete sich die Webseite der Sendung einfach in Vivaldi statt dem Standardbrowser (Opera). Das Problem trat immer nur bei Sendungen des SRF auf und auch da nur bei denen, bei denen die URL zur Webseite defekt war (\u003d in der URL). Diese kaputten URLs waren hier im Forum schon mal ein Thema und treten aktuell wohl nicht mehr auf.

    Vielleicht hilft dir das ja um die Ursache zu finden.



  • Hallo,

    ich habe unter Ubuntu praktisch das gleiche Problem. Unter “Preferred Applications” für Ubuntu habe ich Chromium als Standard-Browser eingestellt. URLs in anderen Anwendungen werden auch korrekt mit Chromium geöffnet. MV dagegen öffnet die URLs stets mit Firefox. Und zwar obwohl ich unter “Einstellungen-Erweitert-Webbrowser zum Öffnen von URLs” Chromium eingestellt habe (/usr/bin/chromium-browser). Firefox war auch schon Mal meine Standard-Browser und MV scheint sich das irgendwie gemerkt zu haben und geht davon auch nicht mehr ab. Seltsam. Scheint mir ein Bug zu sein.


  • Entwickler

    @UbuntuNutzer MV ruft eine Java Funktion zum Starten des Browsers auf. Erst wenn diese fehl schlägt wird der eingestellte Browser verwendet. Ich kann mir durchaus vorstellen dass Oracle dort sich das Leben etwas leicht gemacht hat und immer nur die Standard Browser verwendet.



  • @DerReisende77 sagte in Browser-Auswahl:

    @UbuntuNutzer MV ruft eine Java Funktion zum Starten des Browsers auf. Erst wenn diese fehl schlägt wird der eingestellte Browser verwendet. Ich kann mir durchaus vorstellen dass Oracle dort sich das Leben etwas leicht gemacht hat und immer nur die Standard Browser verwendet.

    Mh - das widerspricht aber meinen Erfahrungen. Bei mir ist Firefox der Standardbrowser und auch in MV als Browser eingestellt. Also müsste zuerst versucht werden, FF zu starten (Standardbrowser) und dann, wenn das nicht geht, nochmal FF (in MV als Browser definiert). Trotzdem wird ab und zu Safari gestartet. MacOS 10.13.6.


  • Entwickler

    @mac-christian Ich war nicht deutlich genug. MV versucht über die Java-Runtime, einen Browser (den Default-Browser) zu starten. Schlägt dies fehl, wird auf OS abseits von macOS der eingestellte Browser gestartet. Unter macOS wird im Fehlerfall eine Safari-Instanz geöffnet da dieser Browser hier immer vorhanden ist. Das Problem ist die Funktion Desktop.browse(…) welche nicht nachvollziehbar manchmal den eingestellten Browser öffnet oder aber einfach auch nur einen Fehler meldet. Hierzu gibt es bei Oracle auch einen bug report und er sollte eigentlich nicht mehr auftreten. Sollte das Problem bei 13.3 weiter bestehen muss ich wohl auch unter macOS einen eingestellten Browser öffnen. Wobei es dann hier höchstwahrscheinlich mit den neueren macOS Versionen nach Mojave Probleme geben wird.
    Ursprünglich war das Einstellen des Browsers nur für die Linux-Welt gedacht da man dort nicht einfach einen Standard-Browser ermitteln konnte. Für macOS hat bisher dies Browser-Wahl immer gut funktioniert.



  • Hallo,

    danke für die Hinweise. Mein Problem war, dass immer nur Firefox gestartet wurde, selbst wenn der Default-Browser Chromium war. Das scheint mir daher kein Java-Problem zu sein. Wie auch immer: Mit 13.3.0 wird jetzt der Default-Browser von MV aufgerufen. Damit hat sich mein Problem gelöst. (“Einstellungen-Erweitert-Webbrowser zum Öffnen von URLs” zeigt aber weiterhin keine Wirkung.)


Log in to reply
 

112
Online

3.5k
Users

2.8k
Topics

18.1k
Posts