Mediathekview braucht 2 Stunden zum Starten



  • Hallo,

    seit vorgestern abend verhält sich Mediathekview bei mir seltsam: Zu Beginn wird ja offenbar die (gespeicherte) Filmliste vom Programm eingelesen, dabei läuft eine Fortschrittsanzeige in Tortenform. Seit vorgestern abend benötigt dieser Vorgang nicht mehr, wie bisher, knappe zwei Minuten, sondern über zwei Stunden. Währenddessen ist Mediathekview nicht bedienbar, d.h. ich kann nicht z.B. Einstellungen verändern o.ä. Anschließend misslingt auch das Laden der aktuellen Filmliste per Internet. Nach entsprechender Fehlermeldung wird die Filmliste neu aufgebaut, das dauert wieder 2 Stunden. Danach ist das Programm normal benutzbar mit veralteter Filmliste.

    Meines Wissens gab es zwischen dem letzten Funktionieren wenige Stunden zuvor und diesem Verhalten keine Änderung am PC (logischerweise muss aber natürlich etwas passiert sein). Java ist aktuell, eine Neuinstallation von Mediathekview hat nichts gebracht.

    Auffällig war für mich nur, dass der Taskmanager anzeigte, dass der Windows Defender während der gesamten Zeit die CPU zu 25-30% auslastet.

    Welche Informationen braucht es um den Ursachen auf die Spur zu kommen?

    Viele Grüße, Wolfgang-P



  • Hallo @Wolfgang-P,

    über das Hilfe-Menü kannst du eine Log-Datei erstellen und hier im Forum hochladen.

    Es gibt in der Tat viele verschiedene mögliche Erklärungen. Eine wäre zu wenig Speicher. Auch wenn du keine entsprechende Meldung bekommst, probier mal, ob dir Nicht genug Arbeitsspeicher zugewiesen hilft.

    Du könntest auch probieren, den Defender zu deaktivieren, auch wenn ich nicht glaube, dass dies den Unterschied zwischen 2 Minuten und 2 Stunden erklärt.

    Nur zu Sicherheit: Welche MV Version verwendest du?

    herbivore



  • Hallo herbivore,

    danke für die Tipps. Ich habe mediathekview immer über die .exe gestartet, so dass es vermutlich nicht an zu wenig zugewiesenem Speicher gelegen haben kann. Eine Log-Datei lade ich hoch, wenn ich genügend Zeit habe - um sie zu bekommen muss ich das Programm ja 2-4 Stunden werkeln lassen. Übrigens verwende ich die aktuellste Version 13.2.1.

    Ich habe probehalber mal die Datenbank gelöscht, kein Unterschied. Dann habe ich die portable Version gestartet - funktioniert prima. Damit habe ich erstmal eine Lösung, mit der ich arbeiten kann.

    Viele Grüße, Wolfgang



  • Hallo, heute habe ich es wieder versucht mit dem gleichen Ergebnis: Mediathekview lädt die Filmliste unglaublich langsam und meldet nach zwei Stunden “Das Laden der Filmliste hat nicht geklappt”. Die Protokolldatei kann ich nicht hochladen, sie ist 11 MB groß und nur 4 MB sind erlaubt, habe sie daher in meine Dropbox gestellt: https://www.dropbox.com/s/g2lm8g7kfg3e7tq/mv_protokoll.tar.gz?dl=0

    Viele Grüße, Wolfgang



  • @Wolfgang-P

    [ERROR] 2019-02-15 11:31:48.945 [pool-5-thread-3] mSearch.daten.DatenFilm - org.h2.jdbc.JdbcSQLException: Referentielle Integrität verletzt: "CONSTRAINT_FE: MEDIATHEKVIEW.WEBSITE_LINKS FOREIGN KEY(ID) REFERENCES MEDIATHEKVIEW.FILM(ID) (52)"
    Referential integrity constraint violation: "CONSTRAINT_FE: MEDIATHEKVIEW.WEBSITE_LINKS FOREIGN KEY(ID) REFERENCES MEDIATHEKVIEW.FILM(ID) (52)"; SQL statement:
    MERGE INTO mediathekview.website_links KEY(ID) VALUES (?,?) [23506-197]
    [ERROR] 2019-02-15 11:31:48.985 [pool-5-thread-4] mSearch.daten.DatenFilm - JdbcSQLException: 
    org.h2.jdbc.JdbcSQLException: Die Datenbank ist bereits geschlossen
    The database has been closed [90098-197]
    

    Du hast permanent solche Fehler.

    Ich hätte die Datenbank (*.db) gelöscht und es noch einmal probiert, aber das hast Du ja schon …



  • @DaDirnbocher Nein, hatte ich nicht - danke für den Hinweis. Nach Löschen der Datenbank startet das Programm jedenfalls beim ersten Mal normal. Schade, dass das Programm die Datenbankfehler dem User nicht meldet.

    Viele Grüße, Wolfgang



  • @Wolfgang-P sagte: Schade, dass das Programm die Datenbankfehler dem User nicht meldet.

    Du kannst auch MV-Version 13.0.6, welche keine DB verwendet, benutzen, bis MV 13.3 solche und ähnliche Probleme behoben haben wird.



  • @Wolfgang-P sagte in Mediathekview braucht 2 Stunden zum Starten:

    @DaDirnbocher Nein, hatte ich nicht - danke für den Hinweis

    Aso. ich hatte

    Ich habe probehalber mal die Datenbank gelöscht, kein Unterschied.

    so interpretiert.

    Hauptsache, dass es jetzt funktioniert.


Log in to reply
 

81
Online

3.0k
Users

2.4k
Topics

14.7k
Posts