Mediatheken-Plugin für Kodi



  • xz ist ein Programm zum Entpacken von xz-Archiven. Ich bin überrascht, dass er das Programm nicht findet, denn bei OSMC für den RPi1 ist es dabei.

    Was gibt which xz in Putty bei dir aus? Es sollte eigentlich /usr/bin/xz sein.



  • @yggdrasil in Deinem Shell-Script verwendest Du:

    UNPACK_XZ=“xz -dc -”

    und rufst das Kommando nachher auf.
    Das Kommando gibt es in meiner OSMC-Installation nicht.
    Leider kenne ich das Kommando auch nicht. Vielleicht sollte ich das mal über apt-get installieren?



  • Ja, das wollte ich auch gerade vorschlagen. Dabei ist mir aufgefallen, dass das Programm bei dir anders heißen könnte. Das Paket ‘xzdec’ stellt nämlich nur xzdec zur Verfügung. Gibt es das bei dir?



  • Bitte probiere mal sudo apt-get install xz-utils Das installiert ‘xz’



  • @yggdrasil Das Paket heisst xy-utils
    und nach dessen Installation scheint alles zu laufen…
    Vielen Dank für Deine Bemühungen!
    Bin mit meinen 63 Jahren nicht mehr ganz so fit…
    Hatte mich gegen LibreELEC und für OSMC entschieden, weil ich ein “richtiges” Debian zur Verfügung haben wollte und ich hatte auch den Eindruck, mit meiner langsamen Internetanbindung lief OSMC stabiler. Vielleicht aber auch Einbildung.
    Jetzt noch was ganz anderes: (hoffentlich fliege ich wegen off Topic nicht aus dem Forum)
    Ich kenne Dein Pseudonym yggdrasil irgend wo anders her kann u.U. auch schon länger her sein , kannst Du mir da auf die Sprünge helfen? ja, ja das Alter…



  • @wohey sagte in Mediatheken-Plugin für Kodi:

    @yggdrasil Das Paket heisst xy-utils

    Um Irritationen bei Mitleser zu vermeiden: Der Paketname lautet xz-utils

    und nach dessen Installation scheint alles zu laufen…
    Vielen Dank für Deine Bemühungen!

    Wunderbar. Ich werde einen Hinweis in die Installations-Anleitung des Addons einfügen.

    Hatte mich gegen LibreELEC und für OSMC entschieden, weil ich ein “richtiges” Debian zur Verfügung haben wollte und ich hatte auch den Eindruck, mit meiner langsamen Internetanbindung lief OSMC stabiler. Vielleicht aber auch Einbildung.

    Es kann durchaus sein, dass die vorgegebene Konfiguration von OSMC besser auf deine Umgebung
    abgestimmt ist als LibreELEC. Bei mir ist genau das Gegenteil der Fall, ohne die Gründe hier zu erläutern, und daher würde ich es nicht verallgemeinern.



  • So, die Änderungen reichten aus, um ein neues Release zu rechtfertigen :) Auf der Startseite ist nun Version 0.8 verlinkt.

    Neben Fehlerbehebungen wurde die Integration in OSMC verbessert
    Außerdem ist nun für den Raspberry Pi 1 eine Option enthalten, welche Kodi während des Updates der Filmliste anhält. Je nach Auslastung des Systems durch das Zeichnen der Kodi-GUI bringt dies einige Sekunden. (Auf meinem Testsystem wird die Grundlast von Kodi im Idle mit 14% angegeben. Da reduziert die Option das Update von 67 Sekunden auf 51.

    Edit: Korrektur 0.8.1 behebt Fehler unter LibreELEC/OpenELEC



  • Gerade mal auf meinem Libreelec Rasp3 installiert, läuft.

    Was nicht geht sind Livestreams. Gut, brauche ich persönlich nicht unbedingt, das liefern mir auch andere plugins.

    Aber vielleicht hilft es ja zur Fehlersuche

    WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.simple_mediathek_de/?j=%7B%22iresult%22%3A+2%2C+%22mode%22%3A+%22select_result%22%2C+%22p
    rev_mode%22%3A+%22show_search_result%22%7D
    
    ERROR: InputStream: Error opening, plugin://plugin.video.simple_mediathek_de/?j=%7B%22iresult%22%3A+0%2C+%22mode%22%3A+%22select_result%22%2C+%22prev_mode%22%3A+%22show_search_result%22%7D


  • Danke für das Feedback.

    @vitusson sagte in Mediatheken-Plugin für Kodi:

    Was nicht geht sind Livestreams.
    Hattest du zu dem Zeitpunkt die Filmliste bereits einmal geladen?



  • @yggdrasil Filmliste war geladen


Anmelden zum Antworten
 

51
Online

1.1k
Benutzer

1.0k
Themen

5.5k
Beiträge

Es scheint als hättest du die Verbindung zu MediathekView-Forum verloren, bitte warte während wir versuchen sie wieder aufzubauen.