MV Portable startet nicht - 13.1



  • Schließe mich meinem Vorredner an.

    Betreibe MV ausschließlich im portablen Modus. 13.0.6 funktionierte stets ohne jedes Problem. 13.1. in eigenes Verzeichnis entpackt. Portable-exe gestartet. Die App schafft es bis zur Grundeinstellung. Beim Versuch, diese abszuspeichern verabschiedet sich MV grußlos und java muss manuell über den Taskmanager gekillt werden (172 MB). Solange es die 13.0.6 tut, bleibe ich halt dabei und mache mir keinen Kopf.

    Ziemlich frisches Windows 7 x64 Ultimate, 8 MB Arbeitsspeicher, 500 GB auf der Festplatte frei. java 8.171, 32 Bit.



  • @orplid präzisiert seinen letzten Beitrag. MV 13.1. stürzt bei mir exakt reproduzierbar nach der Eingabe des Pfads zur VLC-Exe und des Pfads zur Speicherung der Filme ab. Wenn ich nach dem zweiten Bildschirm auf “Weiter” klicke, verschwindet die App, ohne Spuren zu hinterlassen und java muss gekillt werden. Im Verzeichnis .mediathekview3 befinden sich dann zwei Textdateien der Größe 0 (settings.txt und history.txt, wenn ich mich richtig erinnere). Nach dem Neustart der App beginnt das Spiel von vorn.

    Danke
    o



  • Ich bestätige das von orplid geschilderte Verhalten. Bei mir lief MV bis Version 13.0.6 einwandfrei als portables Programm (gestartet mit MediathekView_Portable.exe), aber bei Version 13.1.0 werden zwei .mediathek3-Verzeichnisse angelegt. Im Programmverzeichnis in dem Unterordner “Einstellungen” sind die Dateien “downloadAbos.txt” und “history.txt” enthalten und in .mediathek3 im Userverzeichnis auf der Windowspartition die Dateien “mediathekview.log” und “settings.xml”. Dann geht nichts mehr weiter (keine GUI lädt) und man muß das Programm abschießen.

    Bisher habe ich nur geschaftt, das Programm halbwegs “portabel” zum Laufen zu bringen, wenn ich den vollständigen Pfad zu dem .mediathek3-Verzeichnis angebe:

    java -jar MediathekView.jar D:/Programme/Portable/MediathekView_13_1_0/Einstellungen/.mediathek3

    Dann startet die GUI und die Einstellungen werden im angegebenen Programmverzeichnis gespeichert, aber das Verzeichnis im User-Ordner wird weiterhin angelegt und die beiden genannten Dateien weiterhin dort abgelegt. Das ist für ein portables Programm sicher nicht richtig.

    Ich hoffe, die Informationen reichen, um den Fehler zu finden.

    Danke
    Michael

    Nachtrag: Das erneute Laden der Filmliste gelingt beim Start mit der genannten Befehlszeile nicht (weder automatisch noch manuell). Der Fortschrittsbalken bleibt früh hängen trotz extremer CPU-Last nahe 100 %, so daß auch hier nur das Abschießen hilft (mühsam, denn die CPU wird so beschäftigt, daß selbst der Taskmanager kaum reagiert).

    Alles mit Windows 7 Home Premium und neustem Java 8.0.181.



  • Ich habe das gleiche Verhalten bei der portablen Version. In folgendem Thread haben sich auch andere Leute mit diesem oder einem ähnlichen Problem gemeldet:

    https://forum.mediathekview.de/topic/1535/problem-mit-der-neuen-version-13-1-0

    EDIT:

    Das Problem mit den Einstellungen scheint wohl mehr oder weniger bekannt zu sein:

    https://forum.mediathekview.de/topic/1537/version-13-1-0-einstellungen


 

109
Online

2.1k
Benutzer

1.8k
Themen

10.8k
Beiträge