Downloadverzeichnis über NFS... Ich weiss nicht weiter..



  • Tach zusammen,

    ich bin eben erst hier gelandet, nachdem ich hier echt verzweifelt bin beim Versuch beim MV-Addon die Download-Verzeichnisse einzustellen.

    Ich versuche mal die Situation zu umreißen. Bitte nachfragen, wenn was unklar ist:

    Kodi läuft mit LibreElec auf nem Raspberry Pi 2.
    Alle Medien liegen in einer NFS-Freigabe nfs://ip-adresse//mnt/Datenhalde/Medien/ mit mehreren Unterordnern auf meinem FreeNAS-Server der über WLAN verbunden ist.

    Die NFS-Freigabe lässt sich ohne Probleme schreibend und lesend verwenden, wenn ich’s nicht über das MV-Addon mache.

    Wenn ich die beiden Download-Ordner einstellen möchte, finde ich im Auswahldialog dem kompletten Pfad nfs://ip-adresse//mnt/Datenhalde/Filme auf dem Server zur Auswahl. Den nehme ich als Film-Downloadverzeichnis und alles klappt.

    Wenn ich das Serien-Downloadverzeichnis auswählen will, muss ich also den Pfad nfs://ip-adresse//mnt/Datenhalde/Medien/Serien “zu Fuß” eingeben. Bei den ersten 10 Versuchen bekam ich immer eine Fehlermeldung: “Prüfen Sie, ob das Verzeichnis existiert und schreibbar ist”.

    Später habe ich Kodi einmal komplett zurückgesetzt und neu angefangen. Mit allen Daten auf dem Server geht ja wenig verloren. Nun stehe ich vor dem gleichen Problem, aber die Fehlermeldung kommt nicht mehr. Allerdings kann ich auch das Serien-Downloadverzeichnis nicht festlegen. Es passiert einfach nichts. auf der FreeNAS-Konsole sehe ich auch keine Meldungen.

    Jetzt könnte ich echt ein, zwei Tipps gebrauchen…

    Danke und Grüße aus dem Münsterland, Markus



  • @DamageIncorporated sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    Jetzt könnte ich echt ein, zwei Tipps gebrauchen…

    Zu dem Weg wie Du es versuchst habe ich leider keine direkten Lösungsvorschlag. Aber was ich bei mir mache ist das ich fstab/autofs nutze um die NFS shares zu mounten. Dann brauchst Du Dich nicht in Kodi mit dem NFS Protokoll rumschlagen sondern kannst ganz einfach “lokale” Verzeichnisse nehmen.



  • @media_fread
    Also praktisch so, wie ich es mit dem Desktop schpn seit eh und jeh mache …

    Darauf war ich bisher tatsächlich nicht gekommen, wohl weil ich LibreELEC nur als appliance betrachte an dem ich nichts unter der Haube schrauben wollte. Aber in diesem Fall werde ich wohl eine Ausnahme machen 🙂

    Danke!



  • @DamageIncorporated sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    Tach zusammen,

    ich bin eben erst hier gelandet, nachdem ich hier echt verzweifelt bin beim Versuch beim MV-Addon die Download-Verzeichnisse einzustellen.

    Ich versuche mal die Situation zu umreißen. Bitte nachfragen, wenn was unklar ist:

    Kodi läuft mit LibreElec auf nem Raspberry Pi 2.
    Alle Medien liegen in einer NFS-Freigabe nfs://ip-adresse//mnt/Datenhalde/Medien/ mit mehreren Unterordnern auf meinem FreeNAS-Server der über WLAN verbunden ist.

    Die NFS-Freigabe lässt sich ohne Probleme schreibend und lesend verwenden, wenn ich’s nicht über das MV-Addon mache.

    Wenn ich die beiden Download-Ordner einstellen möchte, finde ich im Auswahldialog dem kompletten Pfad nfs://ip-adresse//mnt/Datenhalde/Filme auf dem Server zur Auswahl. Den nehme ich als Film-Downloadverzeichnis und alles klappt.

    Wenn ich das Serien-Downloadverzeichnis auswählen will, muss ich also den Pfad nfs://ip-adresse//mnt/Datenhalde/Medien/Serien “zu Fuß” eingeben. Bei den ersten 10 Versuchen bekam ich immer eine Fehlermeldung: “Prüfen Sie, ob das Verzeichnis existiert und schreibbar ist”.

    Ich kann dein Problem bei mir nicht nachvollziehen. (aktuelles Libreelec auf Raspi)
    Ich kann hier als Film-Download-Verzeichnis einfach einen Ordner auf meinem nfs-Share per klickibunti auswählen wie ich es auch für das Serienverzeichnis kann, nicht “zu Fuß” (was ich mal als per Hand interpretiere, d.h. du musst eine Pfad eintippen?)
    Was ich hier bei dir sehe sind aber Diskrepanzen im Pfad. Erst sagst du dein export liegt in nfs://ip-adresse//mnt/Datenhalde/Medien/, dann schreibst du deine Filmdownload läge in …mnt/Datenhalde/Filme, was nicht passt wenn Datenhalde/Medien/ dein export ist kannst du nicht in Datenhalde/Filme kommen, nur in Unterordner von …/Medien, bei Serien wiederum schreibst du von …mnt/Datenhalde/Medien/Serien. Also eines von beiden passt nicht.
    Existieren den die Ordner in dem Share?
    PS: Und was sind diese Doppelslashes in deinen Adressen ip-adresse//mnt/…?
    Da kommt nur ein Slash hin.
    Was steht denn in deiner .kodi/userdata/sources.xml zu den nfs-Shares?
    Hier sieht das zB so aus

           <source>
                <name>mediafiles_export</name>
                <path pathversion="1">nfs://192.168.1.20/mnt/Media/mediafiles_export/</path>
                <allowsharing>true</allowsharing>
    

    Und diesen Pfad sehe ich auch im Auswahldialog des Addons und kann dann in dessen Unterordner navigieren, als DL-Verzeichnis.

    PPS: Wenn alles nichts hilft, kann man auch Settings des Addons selbst editieren .kodi/userdata/addon_data/plugin.video.mediathekview/settings.xml

    <setting id="downloadpathep">nfs://192.168.1.20/mnt/Media/mediafiles_export/Serien/</setting>
    <setting id="downloadpathmv">nfs://192.168.1.20/mnt/Media/mediafiles_export/Filme/</setting>
    


  • @vitusson

    @vitusson sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    @DamageIncorporated sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    Tach zusammen,

    ich bin eben erst hier gelandet, nachdem ich hier echt verzweifelt bin beim Versuch beim MV-Addon die Download-Verzeichnisse einzustellen.

    Ich versuche mal die Situation zu umreißen. Bitte nachfragen, wenn was unklar ist:

    Kodi läuft mit LibreElec auf nem Raspberry Pi 2.
    Alle Medien liegen in einer NFS-Freigabe nfs://ip-adresse//mnt/Datenhalde/Medien/ mit mehreren Unterordnern auf meinem FreeNAS-Server der über WLAN verbunden ist.

    Die NFS-Freigabe lässt sich ohne Probleme schreibend und lesend verwenden, wenn ich’s nicht über das MV-Addon mache.

    Wenn ich die beiden Download-Ordner einstellen möchte, finde ich im Auswahldialog dem kompletten Pfad nfs://ip-adresse//mnt/Datenhalde/Filme auf dem Server zur Auswahl. Den nehme ich als Film-Downloadverzeichnis und alles klappt.

    Wenn ich das Serien-Downloadverzeichnis auswählen will, muss ich also den Pfad nfs://ip-adresse//mnt/Datenhalde/Medien/Serien “zu Fuß” eingeben. Bei den ersten 10 Versuchen bekam ich immer eine Fehlermeldung: “Prüfen Sie, ob das Verzeichnis existiert und schreibbar ist”.

    Ich kann dein Problem bei mir nicht nachvollziehen. (aktuelles Libreelec auf Raspi)
    Ich kann hier als Film-Download-Verzeichnis einfach einen Ordner auf meinem nfs-Share per klickibunti auswählen wie ich es auch für das Serienverzeichnis kann, nicht “zu Fuß” (was ich mal als per Hand interpretiere, d.h. du musst eine Pfad eintippen?)

    Genau, so wars gemeint 🙂

    Was ich hier bei dir sehe sind aber Diskrepanzen im Pfad. Erst sagst du dein export liegt in nfs://ip-adresse//mnt/Datenhalde/Medien/, dann schreibst du deine Filmdownload läge in …mnt/Datenhalde/Filme, was nicht passt wenn Datenhalde/Medien/ dein export ist kannst du nicht in Datenhalde/Filme kommen, nur in Unterordner von …/Medien, bei Serien wiederum schreibst du von …mnt/Datenhalde/Medien/Serien. Also eines von beiden passt nicht.

    Das liegt wohl daran, dass ich hier beim Tippen Fehler gemacht habe.
    Hier sind die Pfade jedenfalls einheitlich und da ich gestern nochmal dran war, weiß ich auch, dass es daran nicht gelegen hat 🙂

    Auf der Seite von FreeNAS sieht es so aus:
    Die Freigabe lautet “/mnt/Datenhalde/Medien” darunter befinden sich die Verzeichnisse “Filme”, “Musik” und “Serien”.

    FreeNAS erlaubt auch, einen der Unterordner per mount einzubinden, also nicht nur “Medien” komplett.

    Existieren den die Ordner in dem Share?
    PS: Und was sind diese Doppelslashes in deinen Adressen ip-adresse//mnt/…?
    Da kommt nur ein Slash hin.

    Das hatte ich auch erwartet, aber beim Filme-Ordner der ja von MV erreichbar war, gab der Auswahldialog Doppelslashes vor, daher habe ich angenommen, dass das so vorgesehen war. Es kam mir aber auch seltsam vor.

    Was steht denn in deiner .kodi/userdata/sources.xml zu den nfs-Shares?
    Hier sieht das zB so aus

    Das schaue ich mir nochmal separat an, da war ich bisher noch nicht unterwegs.

    Ich bin jetzt erstmal den Weg mit den lokal eingebundenen NFS-Shares gegangen, so funktioniert es jetzt erstmal. Ichdokumentiere das mal hier für die nächsten Fragesteller*innen, die das Forum durchsuchen:

    Es ist jetzt keine manuelle Änderung in /etc/fstab geworden. Da die Datei im Grundzustand komplett leer ist, wollte ich hier nicht dran, da LibreELEC es offenbar anders macht.

    Eine Websuche, ich glaube nach “LibreELEC NFS” brachte mich auf andere Foren und diese Anleitung bei den Kollegen von OpenELEC:

    https://wiki.openelec.tv/index.php/Mounting_network_shares

    An die habe ich mich gehalten und eine systemd “Regel” erstellt, diesmal auf das “Überverzeichnis” Medien, das hier dann lokal unter /storage/datenhalde/Medien eingebunden wird. darunter befinden sich dann wie oben beschrieben die Ordner “Filme”, “Serien” und auch “Musik”.

    Um das Flickwerk möglichst klein zu halten, habe ich dann nach erfolgreichem Test (Sind die Sachen auch da?) die allgemeinen Video- und Musik-Quellen auf die neuen “lokalen” Ordner umgebogen. Hat geklappt.

    Die MV-Downloadordner zeigen ebenfalls auf die neuen Ordner und so klappt es jetzt auch.

    Beim nächsten LibreELEC Update werde ich das wohl wiederherstellen müssen, daher werde ich es, wenn die Nerven wieder beruhigt sind, nochmal auf die “richtige” Art versuchen und vielleicht sehe ich dann, wo es hier geklemmt hat.

    Danke für eure Hilfestellung und Tipps,

    Grüße aus Beckum, Markus


  • Administrator

    @DamageIncorporated sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    Beim nächsten LibreELEC Update werde ich das wohl wiederherstellen müssen, daher werde ich es, wenn die Nerven wieder beruhigt sind, nochmal auf die “richtige” Art versuchen und vielleicht sehe ich dann, wo es hier geklemmt hat.

    Wenn deine systemd dateien im /storage Ordner sind dürfte das nicht bei einem Update kaputt gehen. Außer du meinst mit einem Update, dass die komplette sd karte neu bespielt wird. Aber ok dann sind auch die generellen einstellungen von kodi weg ^^

    Ich fluche auch jedes mal wenn ich irgendwelche einbindungen in kodi machen will. Meistens klappt es nicht auf anhieb.



  • @DamageIncorporated sagte in Downloadverzeichnis über NFS... Ich weiss nicht weiter..:

    Eine Websuche, ich glaube nach “LibreELEC NFS” brachte mich auf andere Foren und diese Anleitung bei den Kollegen von OpenELEC:

    https://wiki.openelec.tv/index.php/Mounting_network_shares

    An die habe ich mich gehalten und eine systemd “Regel” erstellt, diesmal auf das “Überverzeichnis” Medien, das hier dann lokal unter /storage/datenhalde/Medien eingebunden wird. darunter befinden sich dann wie oben beschrieben die Ordner “Filme”, “Serien” und auch “Musik”.

    Wenn es klappt, ist ja gut.
    Das erklärt trotzdem nicht, wieso es beim mir ohne das unsägliche systemd-Gefrickel geht. NFS-Shares werden eingehängt wenn es gebraucht wird.


Log in to reply
 

37
Online

4.1k
Users

3.4k
Topics

22.2k
Posts